NC 27 - Storage mismatch used vs. actual used space

hello everyone

I do have a slight mismatch of shown used space on the data page of nextcloud vs. the actual used space of the folders (also on the data page of nextcloud)
it’s the first time I have seen this issue after a complete reinstall with a new jail for NC 27

I have seen several threads about storage not showing the right size but that doesn’t apply here, everything is fine in this regard. it is not an actual problem (at the moment) but I am rather interested in figuring out what is happening here

I have tried some straight forward solutions mainly using occ commands, e.g.:

  • files:cleanup
  • files:scan --all
  • maintenance:repair

so far with no luck. any ideas or maybe anyone who faced the same issue?

Nextcloud version: 27.1.2
Operating system and version: TrueNAS 13 Jail / 13.2-RELEASE-p4
Caddy v2.7.5
PHP version: 8.2.11

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' =>
  array (
    0 => 'localhost',
  'datadirectory' => '/mnt/files',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:/var/run/mysql/mysql.sock',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => '',
  'installed' => true,
  'instanceid' => '',
  'logtimezone' => 'Europe/Berlin',
  'default_phone_region' => '',
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud/nextcloud.log',
  'loglevel' => '2',
  'logrotate_size' => '104847600',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'redis' =>
  array (
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
  'memcache.distributed' => '\\OC\\Memcache\\Redis',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'overwritehost' => '',
  'overwriteprotocol' => 'http',
  'htaccess.RewriteBase' => '/',
  'trusted_proxies' =>
  array (
    1 => 'localhost',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => '',
  'mail_domain' => '',
  'mail_smtpauth' => 1,
  'mail_smtphost' => 'smtp.',
  'mail_smtpport' => '587',
  'mail_smtpname' => '',
  'mail_smtppassword' => '',
  'maintenance' => false,

You deleted the file versions and trash bin as well? They might occupy space (“used space”) but do not directly show up in the file tree…

hello there

I deleted all files in trash - is there a way to delete all old file versions? however, I have a fresh installation of NC so I’m not sure there are much old versions around
also, I double checked the size of the according folders (files_trashbin & files_version) and they are about 17 mb at the moment - seems about right I think

I have checked on my setup, one user, the storage is same for both indicators, on a second test setup, I see also a difference (38 GB vs 41 GB). I checked with du -A on the file system, and the 38 GB seems to be the actual size of all files. 39 GB would be the size used on the drive (due to sector size), but I don’t get up to 41 GB. Trash bin (12 GB) and versions (1.9 MB) don’t explain the different either.

We had the discussion before, and it went probably to github as well, where you find a bit more information where the information comes from and how it is calculated. I currently can’t find it. Perhaps it could be linked with other storages (I had a few external storages linked at some time, perhaps some count into it or not, perhaps the groupfolder. Since it is a test instance, I tried a lot of things).

thanks for the info
in my case, nothing to do with external spaces. I’ll see if I can find anything on github

either way: it’s not important as it does not seem to have any negative impact.

thanks for your help

Update to 27.1.3 corrected the mismatch …
I’ll mark as solved