NC 23 - Office (Collabora) Document Loading Failed

I just upgraded to Nextcloud 23, and suddenly my collabora server doesn work.

The server is still reachable but when I try to open any document I get the following error:
Document Loading Failed
Failed to load Nextcloud Office - please try again later

/var/www/html/nextcloud/data/nextcloud.log has no recent logs.

Collabora was working just fine and all I did was upgrade nextcloud.

I thought Nextcloud Office was just collabora online?
Does this new nextcloud “office” feature not actually support the collabora coolwsd dedicated server?

A couple of us noticed an issue with the latest collabora docker container 21.11.3.3.1 that was released yesterday. There is a thread on the collabora forum.

https://forum.collaboraonline.com/t/problem-moving-from-21-11-2-4-to-21-11-3-3-1/981

In the mean time if you try the 21.11.2.4 container, it should work.

I don’t use containers, I am using a full ubuntu VM and a debian VM for collabora.

Well all i can say, this latest container update aside, that in general NC23 works fine with the collabora document server. Perhaps check your reverse proxy and that it meets the current guide lines? (They made some major changes back in January).

https://sdk.collaboraonline.com/docs/installation/Proxy_settings.html

I installed the coolwsd server only about 2 weeks ago. It is up to date with the most current documentation.

None of my configurations have changed, all I did was update nextcloud, and the collabora coolwsd suddenly doesn’t work.
I should add the admin console for coolwsd displays the document is opened, but it just doesn’t display in nextcloud.

Hmm, that is odd. I would guess, and this is a really rough guess from what you are saying, your nexcloud server can reach the document server. (or there would be no entry in the admin panel) but your document server is having trouble reaching back to your nextcloud server.

On the collabora VM, I can curl the nextcloud URL and it connects no problem.

I do not know exactly how collabora operates (hence why Im asking in general), so I am not sure if that general connection means its good to go or not.

I did see mention in the change logs about switching document rendering to the browser, but I also read that the regular collabora online coolwsd does all of its rendering server-side.
I have seen nowhere that there needs to be modifications to the coolwsd configuration to support this new rendering config. If there is new documentation about implementing this rendering solution, please link it as that would be most likely what I am missing.

To add, my general network architecture is a reverse proxy terminating TLS and forwarding to both the nextcloud ubuntu server and collabora coolwsd server.

What I’ve ran into with nc23 is every time the server gets restarted, i suddenly can’t load docs, they just want to download.

The fix for me (I’m running code, not a “real” collabora server) is to go into collabora setup, click the radio button to one of the options other than code, then click back to code. Voila, or works again. [Until next reboot]

I’ve tried changing from standalone to code and back, uninstalling the app reinstalling, rebooting nextcloud and the standalone collabora.
Nothing gets the document to load.
To be clear, the document starts to open in the new UI, but just fails to load the actual document.

Screenshot of the error

The new UI also has some color conflicts with the breeze dark theme (hence white on white text)

Almost stupid question: have you tried more than once? Some times right after a change like that, the doc just hangs until I close and try again. Also try ctrl-f5 to clear cache and reload.

Not a stupid question, but yes I have tried many many times to open the document. Cleared the cache, restarted the browser, and restarted my client machine.
Same error.