NC 21 and Talk 11 not wroking after migration to nc21 [solved]

After upgrading vom NC20.x to NC 21 and talk 11
talk as not workin, seems something in the migration went wrong.
disable and removing talk was not working.
however here is the work around

i guess solved the quick and dirty way but who cares …

:warning: Do not do this, see NC 21 and Talk 11 not wroking after migration to nc21 [solved] - #6 by nickvergessen :warning:

1) deaktivate and remove the app (spreed / talk) 
2) open mysql user your database
** clean the migration entry for talk/ spreed** 
3) MariaDB [nextcloud]> select * from oc_migrations where app like '%spreed%' ;
4) MariaDB [nextcloud]> delete from oc_migrations where app='spreed';
** to check **
5) MariaDB [nextcloud]> select * from oc_migrations where app like '%spreed%' ;   
** do 3) 4) 5) again with talk **
** delete the leftovers from the previous install, otherwise you'll get an error when installing the app **
6) MariaDB [nextcloud]> select sip_enabled from oc_talk_rooms;
7) MariaDB [nextcloud]> ALTER TABLE oc_talk_rooms DROP COLUMN sip_enabled
8) installing talk again

and it is working !

the only thing i lost … all communication rooms and chats …
so be aware !
–/warning –


Thanks, that worked!

1 Like

cool thing … !
glad someone can use it too

BTW I got the call history back, so nothing has been lost! Thanks !

great … wasnt that important here
and a cleared up talk is fine too i guess :wink:

1 Like

Do NOT manually interfer and mess up the migrations table!
If you think you have to do that please instead post exact steps what you did.

yes true but it was the only work around to get talk to work after upgrade
and the issue … well …was kind a known for about 20d or so …
before i do a rollback to the prev version … … … not only NC but php and mariaDB as well you try to fix things

and be honest, after you checked the steps and the db affected provided
in my post before and after the system and compared it to a fresh install
you’ll get to the conclusion it is exactly the same

so no harm done
as far as i’ve seen, am i missin somethng?

this wholet hing reminds me of the upgrade of collabora, where some modification (chmod) was needed after every single update, somehow in NC20.x it was workin out of the box … … thats life in openSource Software i guess

Please do not blame me, but I hope my issue is close to yours and not worth to open a new topic.

I’ve migrated successfully to NC21 and Talk 11.1.1 but all my rooms and chats are gone except the changelog room. All comments still exist in the “message”-column inside the table “oc_comments”.

Unlike @n0plan I’m able to create new rooms and messages without any problems.

as i mentioned
the rooms and the comments are not that important to me.
i can generate and use new rooms as before so Talk is workin fine.

as a matter of fact, we ar not going to do uptadtes in the near future :wink: