NC 20 upgrade jammed. Now what?

My NC 19 install finally offered me an upgrade to NC 20.0.4. Cool, I tried to run it. The updater downloaded fine, but then errored out in the verification step with no message. (The “show message” expander was empty.)

Now when I go to try again, I get a message “Step 5 is currently in process. Please reload this page later.”

Now what do I do? :slight_smile:

I had similar problems in the past and I think occ maintenance:repair worked in my case.

I Also had the problem,
@jospoortvliet told this could be a problem due to the downloadserver being overloaded because of the popularity of Nextcloud.
If you have problems with updating the server, just wait a few hours/days and it should not be a problem anymore.

Well, @Erebos’ suggestion fixed the jam. Thanks! A second attempt results in the same validation error, though, even with fresh download.

Could the download file on the server be corrupted? Is it on GCP? :slight_smile:

Issue is still present. This is the error in the updater:


The empty detailed box makes me wonder if the NC servers are just not sending back data at all?

I get that error but the box below contains this:

<title>504 Gateway Timeout</title>
<h1>Gateway Timeout</h1>
<p>The gateway did not receive a timely response
from the upstream server or application.</p>
<address>Apache/2.4.43 (Ubuntu) Server at Port 443</address>

Any suggestions as to what is up?

I tried the update from 20.03 to 20.04 twice and failed with this error both times.

It’s a pity because I thought I had cured the upgrade issues a while ago an have had three successful upgrades since the last time this occurred.
The thing is, I seem to have managed to download the zip file as it’s lying in my nextcloud_data folder inside an update folder.

I may just go to the manual update process again which is tedious :confused:

Ok, I went to the data folder and deleted the hidden .step file which is basically the file that tells NC at which step of the update it is, and therefore is stuck after a failed update.
Once that is deleted you can initiate another upgrade which worked for me this time. That was third attempt for me

Hm, i have no such folder, and it still fails for me.

I’m sure there are other threads in this forum thatdeal with this, it’s where I found out about it. I worry that if I try to go too deep into this fix it might be the bling leading the blind :slight_smile:
The file I deleted is a hidden file, hence it starts with a .
It is located inside your nextcloud data folder (wherever you are storing it, the default is in /var/www/nextcloud/data? Mine is in a different location but, even if it were to be in the default location I have my installation in /var/www/html/nextcloud.
After you try a web based update there will be a new folder inside your data folder called updater-oc** The stars represent a string of characters which I assume are unique to the update process in question, my current one is updater-oc4repx2mfk4
Inside that folder you will find a .step file and/or a .step-previous-update file
They are hidden so you need to do a ls -a to see these.
I deleted both of them and restarted the upgrade which, in this case, worked however, in the past, this has only allowed the upgrade to start again and then subsequently fail again requiring more detailed tweaking. There are other threads on this forum as I said which go into this (known) issue in much more detail.
As I say, my knowledge and skills in the arena of Linux command line are limited and I am pretty much relying on others expertise and poking around in the dark. My server is NOT production/critical but is just a hobby/experient for the time being.
If anything I have typed here helsp you then grweat but, if not, then I’m sorry I couldn’t help :slight_smile:

I’m familiar with how dot files work, and how to show them. But I have no .step file in my data directory, even while the upgrade is jammed.

Running maintenance:repair unjams the update, but repeated attempts still fail with the same issue. Whatever the problem is, it’s not a transient issue.

That is definitely a time-out due to an overloaded download server. We are getting better at not overloading our servers but every time, we get more users :see_no_evil:

It’s an endless fight :ocean: sorry for that. I’m a bit frustrated to read that some still have problems as we really made progress lately :cry:

But I’ll ask sysadmin to keep an even closer eye on the servers.

One tip: upgrade over Christmas, it is hopefully quiet :wink:

i had the same issue and finally I managed to upgrade with the manual upgrade as it is described in the Admin Manual Upgrade manually

My issue (this time) seemed to be, as suggested, a server logjam. It completed a day or so later without any further tweaking from me.
Thanks all for advice and input.


The 20.0.4 upgrade never did work for me. I ended up just waiting for 20.0.5, which worked fine.

Now I’m on 20.0.8, and I’ve gotten the same issue trying to upgrade to 20.0.9, and now to 20.0.10. I don’t know what the issue is but it’s not going away.

I have started downloading the zip file manually (after the updater fails at download) and saving it in the nextcloud/data/updaterxxxxxxx/downloads folder Then, open the .step file in the updater folder which has been created by the web updater program.
IN this .step file there will be an entry like this:
{“state”: “start”, “step”:4}
edit the “start” to an “end” and save that file.
Now open the web updater again and it will continue on to stel 5 and hopefully complete the job :slight_smile:
This has worked for me three times now and I expect to have to do it these days.
Of course, all of this sort of bombs the idea that the NC server is just overloaded because the file manually downloads without issue?

Such is life at the pointy end :slight_smile: