NC 19 on a Debian 9 server


I used NC quite a while on my server without problems. Recently I noticed that NC went for unknown reason in the maintainance modus. Also resulting in errors like service unavailable, meaning nothing could been done.
A few hours later I was able again to log in and being greeted by a message that an .ocdata file was missing. But it was there.
Anyhow I secured my files and did a complete re-install via the webinstaller. Sofar so good. I can go as far as to the point where admin user / data directory and database are defined.
Klicking on enter we end up again with “503 Service Temporarily Unavailable”

I can repeat that over and over again.
PHP-FPM service is running before and after I start installation
The apache errorlog just says something like …/var/www/vhosts/default/htdocs/status,php not found or missing

Any clue on how to proceed here


I think we need more informations and logs. Sorry.

Why do you use Debian 9 (OldStable) and not Debian 10 (Stable). In Debian 10 you get newer php-version, … Why do you use a “webinstaller” and not the normal installation?

Perhaps you use this documentation for install Nextcloud on Debian 10 Buster. But first dist-upgrade from Stretch to Buster. That works for me fine.

tks for yr reply. NC was working very well on my server for quite some time. Starting from Vers.16 to 17 and finally 18. Some days ago I noticed that the mobile clients could not upload files anymore. The error message was simply saying that NC was in Maintainance mode. Whilst openen the webpage on the pc I was greeted by a message saying the file “.ocdata” was missing etc etc. I guess a few other users had this experience. Following the recommondations I found here , namely change to “cron” jobs It ended with the 503 issue.
Instead of playing around any longer I decided to reinstall and use the latest version.
But basically same result as discribed.

Why I’m still on Stretch, good question :slight_smile: I will change that soonest. But first I need to verify that all other webpages/domains hosted on my server can survive the upgrade.

And why the net installer ? It worked well. That it failed on the last step has nothing to do with the way of installation, I think.

Which logfile should be checked ?


Your webserver logs and your nextcloud logs.

Do you use …/var/www/vhosts/default/htdocs for your nextcloud installation? If not verify your vhost-configuration for nextcloud.

it seems this thread ( Service Temporarily Unavailable, AH01067: Failed to read FastCGI header, Nextcloud auf Ubuntu mit Plesk](Service Temporarily Unavailable, AH01067: Failed to read FastCGI header, Nextcloud auf Ubuntu mit Plesk)
covers my issue as well.
I can pinpoint the first occurence of the error to the 14th/15th July
failed to read “FastCGI header”
I used PHP 7.2.32 before and now 7.3.20

Tks Henning

I think it is more likely a problem in your webserver (vhost) or nextcloud configuration. Please check your configurations and post more details and logs.

there are quite (quiet?) a lot of postings related to this version of php and error 503. seems to be broken.

Problem solved by upgrading the server to PHP 7.4.8.
Everything back to normal… Fingers crossed


1 Like


Can you please post for other people where you get the php-version for Debian 9 Stretch.
Or do you have dist-upgraded to Debian 10 Buster? (Stretch PHP 7.0) (Buster PHP 7.3)


my server works with “Plesk Obsidian” and Plesk offers an upgrade via the Plesk Installer
I wish I had seen the upgrade possibility a bit earlier :slight_smile: