NC 18 Bug: advanced permission rule dialog on groupfolders disapears


the advanced permission rule dialog for groupfolders in the sharing sidebar is often disappearing. You have to reload the page (often several times) for it to reappear. I was able to reproduce this on two different Nextcloud instances.

thx for checking!

1 Like

I have the same problem with the admin account. It seems that users account dont encounter this problem.

here it affects also normal accounts…

I have this problem also (v18.0.4) with normal account.
Sometimes reload page or open/close sidebar helps.
I run it on a raspberry. So maybe its a timeout problem?

I don’t think. Sometimes, I have to disconnect my account and connect again to see the advanced permission rule dialog.


We have the same trouble (administrator and user) with version 18.0.4. For the moment I haven’t identify any pattern to make the advanced rules appear systematically.

Thanks for your help.

We’re experiencing the same! We found two issues on GH (#894 and #744), one of the two is assigned but there’s no activity going on :frowning:

Anyone willing to debug, since it’s randomly happening, I found the dialog visibility is conditioned by a param returned by the PROPFIND call. When this is happening it could be an idea to check if the param is correctly returned. On the issue a dev is also asking if there are browser console errors when the dialog is not visible.

For me, same error when use Firefox, but works fine in Google Chrome.

1 Like

I can confirm this bug on NC20 and with Firefox 82.0. Works fine in Chrome-based browser.