NC 16 broken after php 7.3 -> 7.2 downgrade [SOLVED]

Hi there!

I had to downgrade my php7.3 to 7.2 because of the requirements of a different app.

Now my Nextcloud instance (version 16.0.5) will only show this response:

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

The last lines in nextcloud_data/nextcloud.log have a timestamp from before the downgrade and I therefore guess they are unrelated to my problem:

{"reqId":"1p83WUP8tUiWLJWd5XC4","level":3,"time":"2019-12-08T10:20:34+00:00","remoteAddr":"999.999.999.999","user":"--","app":"PHP","method":"PROPFIND","url":"\/nextcloud\/remote.php\/dav\/files\/user\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Linux) mirall\/2.6.1git (Nextcloud)","version":"16.0.5.1"}
{"reqId":"5kXaABo6GAvH38SgYV3C","level":3,"time":"2019-12-08T10:20:36+00:00","remoteAddr":"999.999.999.999","user":"--","app":"PHP","method":"PROPFIND","url":"\/nextcloud\/remote.php\/dav\/files\/user\/","message":"Error: Class 'OCA\\DAV\\Connector\\Sabre\\ExceptionLoggerPlugin' not found at \/var\/www\/html\/nextcloud\/remote.php#57","userAgent":"Mozilla\/5.0 (Linux) mirall\/2.6.1git (Nextcloud)","version":"16.0.5.1"}
{"reqId":"5kXaABo6GAvH38SgYV3C","level":3,"time":"2019-12-08T10:20:36+00:00","remoteAddr":"999.999.999.999","user":"--","app":"PHP","method":"PROPFIND","url":"\/nextcloud\/remote.php\/dav\/files\/user\/","message":"You are using a fallback implementation of the intl extension. Installing the native one is highly recommended instead. at \/var\/www\/html\/nextcloud\/3rdparty\/patchwork\/utf8\/src\/Patchwork\/Utf8\/Bootup\/intl.php#18","userAgent":"Mozilla\/5.0 (Linux) mirall\/2.6.1git (Nextcloud)","version":"16.0.5.1"}
Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 16.0.5.1
Operating system and version (eg, Ubuntu 17.04): Debian 10
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.38
PHP version (eg, 7.1): 7.2.25-1+0~20191128.32+debian10~1.gbp108445

The output of your Nextcloud log in Admin > Logging:
-> sorry, currently can’t get in :frowning:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'debug' => true,
  'instanceid' => 'ocvsk7rjf6qo',
  'passwordsalt' => 'lay22A/VPMD/UNP2oCa7TPrt7qaHwC',
  'secret' => '+Z9SVFR/gHssj40efY1uD52v1YZLtbXpcmZdtOZdc78qVR/Y',
  'trusted_domains' => 
  array (
    0 => 'local ip',
    1 => 'domain 1',
    2 => 'domain 2',
  ),
  'datadirectory' => '/var/www/nextcloud_data',
  'overwrite.cli.url' => 'http://local-ip/nextcloud',
  'dbtype' => 'mysql',
  'version' => '16.0.5.1',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'prefix_',
  'dbuser' => 'user',
  'dbpassword' => 'password',
  'installed' => true,
  'mail_from_address' => 'sender',
  'mail_smtpmode' => 'smtp',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_domain' => 'gmail.com',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'updater.release.channel' => 'stable',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'mail_smtphost' => 'smtp server',
  'mail_sendmailmode' => 'smtp',
  'mail_smtpauth' => 1,
  'mail_smtpport' => '587',
  'mail_smtpname' => 'mail-adresss',
  'mail_smtppassword' => 'password',
  'mail_smtpdebug' => true,
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' => 
  array (
  ),
  'twofactor_enforced_excluded_groups' => 
  array (
  ),
  'mail_smtpsecure' => 'tls',
  'app_install_overwrite' => 
  array (
    0 => 'spreed',
  ),
  'mysql.utf8mb4' => true,
  'filelocking.enabled' => false,
);

The output of your Apache/nginx/system log in /var/log/____:
-> couldn’t find anything relating to nextcloud since the php downgrade

Can you check your server error log?

The message is just about the intl extensions which is recommended to install (probably not related to your problem)

where do I find that “server error log”? I can’t find anything in apache error.log and access.log that seems related.

That’s normally the good ones. Try to install the intl extension, check if you have the other required modules installed: https://docs.nextcloud.com/server/16/admin_manual/installation/source_installation.html#prerequisites-for-manual-installation

For the error in your nextcloud.log (exception logger), I found issues where this was related to the APCU or memcache, so I’d try next to disable them temporarily (uncomment in your config.php). Also make sure that on the commandline and on your webserver you use the same php version (php -v on command line, put a test.php in your webspace with <?php phpinfo(); ?>).

Thank you for your help, I found the problem, the information from my first post was sufficient to find it:

Error: Class ‘OCA\DAV\Connector\Sabre\ExceptionLoggerPlugin’ not found

lead me to this thread:

which told me it’s about the APCu php object cache. I did configure that for php 7.3 when I set up my nextcloud on this server, but I forgot about it when downgrading to php 7.2.

But since my NC config.php tells it to use APCu that broke it since it was not available.

After installing php7.2-apcu & php7.2-fpm and restarted apache2 it works again as it used to :slight_smile:

2 Likes