NC 14 install on Synology uses IPv6 address of client

I tried to install NC14 on my new Synology NAS. I got a fail error.

In the message is an IPv6 address. But that is the address of the client computer I use, not the actual IPv6 address of the server.

Since websites on virtual hosts work correctly, there must be something wrong in the installation procedure. It does not get the correct server IPv6 address! And IPv6 is preferred so a fall back to IPv4 can only be archieved by disabling all IPv6.

After disabling IPv6 on the network interface and rebooting I get my internal client computer IPv4 address and not the server address. The server is on a subnet IPv4 and IPv6 with external access.


Sorry, but at least I don’t understand the issue.
Could you please paste the error message here and shortly explain what you tried to do when the error message appeared and what exactly doesn’t work.

Please also post meaningful log messages from nextcloud.log and the webserver log.

I found the answer myself.
When creating a virtual host on the Synology, only read access is geven. Then Nextcloud seems to take over the client address. After enabling Write acces to the folder, Nextcloud install went fine.

I’d expect a warming about missing write rights. Perhaps for a next release?