NC 12.0.3 cannot sync via CalDAV, CardDAV to Mac OS (El Capitan)

I must first say that I can easily access my self-hosted instance of NC from a remote machine El Capitan. However, when I try to add either a CardDAV or CalDAV account using the same settings, the connection is always refused.

The error log throws out the following: 443:0 server certificate does NOT include an ID which matches the server name

When I initially logged onto my cloud through the browser I was offered the opportunity to accept my apparently dubious self-signed certificate. I accepted it as I have always done. Unfortunately, it now appears that this acceptance does not carry through to other programs such as Mail and Calendar.

Any idea how I might be able to overcome this?

Sorry to tell you that but :

From 10.11, macOS Calendars and Contacts won’t accept self signed certificate.
You have just one exception if your caldav or carddav come from OS X Server 5, there you can have self signed cert.

You must have a good cert in order to make it work.
Look at certbot from EFF.

Thanks Nemskiller. However, I can’t accept that answer because I’m currently running and have been running 10.11 for quite some time without these issues. My calendars and Contacts had been syncing perfectly up until a week or so ago.

Any other hints at what the problem might be?

Strange because from iOS 10 ans OS X 10.11 things get worse for self signed.

You could try that :
Create a new account Caldav in the calendar app :
Server :
Login : yourusername
Password : yourpassword

Do you have automatic updates on on your system ?

The error log throws this out:

AH01630: Client denied by server configuration: var/www/html/nextcloud/data/.ocdata

Another important point to know: I recently upgraded NC and now use MySQL instead of SQLite.

Maybe I’ll dump the program again and try with the other database…

No, after having lost functionality of certain peripheries when updating to El Capitan from Yosemite, I hesitate to even manually change my OS version!

  • Although I am almost certain that this is moot in this situation, I have no choice but to self-sign because I must use a DDNS

Hmm… should the .ocdata file be empty? Mine is completely devoid of any data (0 B)

Another exception that i saw with my Boss computer some years ago.
1- use Yosemite, add your calendar with self sign cert
2- upgrade to el capitan
3- happyly use your calendar
4- delete it, re-add it, god it won’t work
4bis- or wait some times and it won’t sync with a warning triangle.

For using Certbot, you can use it if you have a DDNS, use the manual fonction with the —prefered-chalenges DNS. You will have a 90days cert and you can add it to your nextcloud. It takes 3 minutes when you get used to it

Mine .ocdata have the same weight

Disabled the following



Still no joy. I’m starting to think about throwing something…:grimacing:

SUCCESS! …sort of…

I removed all traces of NC 12.0.3 and then reinstalled it onto my server. Rather than using a MySQL database this time, I chose the the default SQLite option. As a result, I was able to add the DAV accounts to Mail and Calendar without any grief whatsoever!


  • NC 12.0.3 CalDAV and CardDAV do not work on El Capitan when using a MySQL database
  • NC 12.0.3 CalDAV and CardDAV do work on El Capitan when using a SQLite database

Any idea why this would happen?

I was a bit too quick on the draw. CalDAV sync with “Calendar” worked. However, when I had later tried to sync “Mail”, I was refused entry. Did some more digging… Decided to clear the bruteforce entries in my SQLite database before trying again. EUREKA: It worked. Now I can sync contacts and calendar events on my Apfel!

The above leads me to believe that the use of one database over the other may not make a difference.

It’s unfortunate that I had to go through all of the grief and anguish to get to this point of bliss. Did others not experience the same thing or was I the only one as a result of unique vagaries of my system?