NC 11: upgrade, maintenance mode

I did an manual upgrade to NC 11 (from 10.0.2).
I used the procedure described in the NC manual:
I turned on the maintenance mode and move all the files and after I called occ upgrade I got this message:

After disabling the maintenance mode it worked, but I also had to disable it again after the update.
I have done several manual updates but this never happened. Is this intentional, did i miss something?

So now you can’t open Nextcloud? What version is shown in config/config.php?

It looks like the occ upgrade command now expects maintenance mode to be disabled and will enable it by himself.
At least it says: “remove the "maintenance mode" from config.php and call this script again.” But ya this should be changed back or the admin manual should be adjusted to not contain the “Put your server in maintenance mode.” part anymore for consistency.

As you can see in the picture, I turned off the maintenance mode and tried it again, then it worked. And I can open Nextcloud. I was just confused because I never experienced that and I was not sure if i missed something or did something wrong.

@MichaIng I think you need the maintenance mode earlier anyway (when you rename the actual installation and copy over the new one). I think it is OK that the updater enables the maintenance mode if it is not done yet but now it thinks there is already an update running.

Yes that’s true, maintenance mode should be anyway enabled earlier. If not done, I agree that the updater should do it. If it is already enabled the updater should still go on but of course two parallel installation precesses must be avoided! There is this “installed” parameter in config.php, but it is not useful to indicate a running installation precess. For new installations i.e. this should be “false” at the beginning which could also indicate a running installation. But ya I guess there is a good way to check if updater app or occ upgrade command is running ;).

Best would be to double check on a fresh system if you get this error when you follow the manual with enabling the maintenance mode manually first.