NC 11.0.0.3 - Maximum upload size

I am having trouble with figure out why is “maximum upload size” from admin page under “Additional Settings” is not working on new install of NC 11.0.3. I can modify size in that radio window and it will indicate that it is saved. After lets say modifying “Maximum upload size” to 50 MB, I can still upload 5G plus in size files.

So I tried modifying two fields (upload_max_filesize and post_max_size) in php.ini as it worked for me on NC10/11 but for some reason it is not working on my new install of Nextcloud 11.0.3 (stable). Whatever I modify php.ini to it does reflect “maximum upload size” in Admin page.

Alternatively I can setup a rule under “File access Control” which would disallow files from been uploaded if they are let’s say 50MB in size and belong to a specific group of users.

Did anyone ran into this issue by any chance? In NC 11 Admin Manual" it states “Disable user quotas, which makes them unlimited” which doesn’t make sense to me.

Thank you in advance.

Here is my setup:

PHP Version: 7.0.10
Memory Limit: 128.0 MB
Max Execution Time: 3600
Upload max size: 300.0 MB
OS: RHEL 7.3
Nextcloud version: 11.0.3

Still troubleshooting this on my end. I have pull up a phpinfo.php on server and confirmed that whats in /etc/opt/rh/rh-php70/php.ini matches as far as “upload_max_filesize” and “post_max_size”.

Same problem here!