Nach Update von Debian Stretch auf Buster - Error 500?

Hallo zusammen,

bin gerade etwas am verzweifeln: Heute auf meinem Bananapi das Update von Stretch auf Buster angestoßen. Das Update lief relativ unspecktakulär durch.
Es gab jedoch ein paar Probleme mit den vorherigen PHP Versionen die unter Stretch aus von
deb https://packages.sury.org/php/ stretch main
installiert waren. Das konnte ich auch lösen so das PHP korrekt unter Buster installiert ist.
Debian Buster machte nach dem Update ein paar Probleme wegen des opcache’s

Fatal Error opcache.file_cache_only is set without a proper setting of opcache.file_cache

Dieses ließ sich auch relativ schnell lösen. Seit dem bekomme ich allerdings nur noch einen 500 Fehler und ich kann keinen Fehler mehr finden. Nextcloud 17 lief bis zum Update perfekt.

Möglicherweise irgend jemand eine Idee?

Dies findet man zu besagtem Fehler 500, wenn man die Suchfunktion des Forums verwendet:

https://help.nextcloud.com/search?q=error%20500

Ein Fehler 500 ist grundsätzlich ein vom Interpreter erzeugter Fehler. D.h. aktiviere das PHP-Error-Logfile. Dann erzeuge den Fehler, dann schaue ins Logfile. In der Regel wird das in der Syslog protokolliert.

Es taucht merkw√ľrdigerweise wieder der Fehler:

Fatal Error opcache.file_cache_only is set without a proper setting of opcache.file_cache

auf?

Hast Du schon Tante G. befragt?

https://www.google.com/search?client=firefox-b-d&q=Fatal+Error+opcache.file_cache_only+is+set+without+a+proper+setting+of+opcache.file_cache

Habe ich, nat√ľrlich‚Ķ Problem bleibt bestehen! Im Moment ist die Fehlermeldung weg allerdings bleibt die Seite wei√ü und der Output an Infos in den Logs ist nahezu null.

Durch das Update wurde auf Deinem System mit Sicherheit eine neue PHP-Version installiert. Das bedeutet, dass Du unter /etc/php/(versionsnummer)/‚Ķ die Einstellungen pr√ľfen musst. Dir fehlt augenscheinlich die Konfiguration f√ľr ‚Äúopcache.file_cache‚ÄĚ.

Eigentlich alles erledigt. Die vorherige PHP Version 7.3 aus dem sury Repository habe ich gegen die in Debian Buster 7.3 enthaltenden getauscht.

Die Anpassungen in meiner php.ini /etc/php/7.3/cli sehen so aus:

zend_extension=opcache.so
opcache.enable=1
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=10000
opcache.revalidate_freq=180
opcache.fast_shutdown=0
opcache.enable_cli=1
opcache.revalidate_path=0
opcache.validate_timestamps=1
opcache.max_file_size=0
opcache.file_cache=/home/www/opcache
opcache.file_cache_only=1

Der Pfad /home/www/opache hat die Apache Berechtigungen von www-data.

Möglicherweise noch eine Idee?