N23 security and configuration warning

Support intro

Nextcloud version (eg, 20.0.5) : 23.0.0.10
Operating system and version (eg, Ubuntu 20.04) : debian 10
Apache or nginx version (eg, Apache 2.4.25) : Apache 2.4
PHP version (eg, 7.4) : PHP 7.3.19-1
Mariadb: 10.3.22

Hello, I recently had a security and configuration warning following an update.

Here is the defect:
"
There are some warnings about your configuration.
You currently have PHP 7.3.19-1~deb10u1. Upgrade your PHP version to take advantage of the performance improvements and security fixes provided by the PHP group as soon as your distribution supports them.
Nextcloud 23 is the last release supporting PHP 7.3. Nextcloud 24 requires at least PHP 7.4.
"
If I understand correctly, I have to upgrade debian, then upgrade PHP.

I’m afraid to break everything, where should I start?

Thank you for your insights

Normally you can use the default PHP-version in your debian release.
With dist-upgrade from Buster to Bullseye you get PHP 7.4.

Buster, PHP 7.3: https://packages.debian.org/buster/php
Bullseye, PHP 7.4: https://packages.debian.org/bullseye/php

You do not need to install PHP 8 in Bullseye.
Wait with PHP 8 if you do not need it.

Please dist-upgrade from Buster to Bullseye and all is fine.
Make a backup.

Hello,

I did the update without any problems.

Just a small PHP error concerning the memory limit.

Thanks

1 Like

Is it possible to use dist-upgrade with nextcloudpi and raspberry pi 4, too?

I think.
it’s the Debian update