MySQL Installation NC10.0 gives Error

A new fresh installation (MariaDb/MySQL) gives me the following error:
Error while trying to create admin user: Failed to connect to the database:
An exception occured in driver: SQLSTATE[HY000] [1044] Access denied for user ‘occta4’@‘localhost’ to database …_

The Installer use always an oc_cta(#) db-user. My db-user-name was ignored.

Hello there.
This seems to be a credentials issue with MySQL.
What is the installer you are referencing ? Can you tell us more about your setup ?
Regards.

Hello aalaesar

My system:

  • Ubuntu Server 16.04
  • Apache/2.4.18 (Ubuntu)
  • 10.0.25-MariaDB-0ubuntu0.16.04.1
  • PHP 7.0.8-0ubuntu0.16.04.2 (FCGI)
  • Nextcloud 10.0

If I connect to the (empty) db with adminer or via shell it works perfectly. I have a running Nextcloud 9.0.53 installation on the same server without any problems.

Regards

I have the same system configuration and the setup wouldn’t work with strong passwords (I use keepass to generate passwords). I had to use a weak password (like ‘test’) and then the setup worked fine. If I changed the db password after then I couldn’t connect to the database from the browser (error 500) and the log indicated that it was a db login issue. If I changed the db password in the config.php file to match the new password, it took me back to the setup screen. I just need to know how to change the db password to a strong one after the successful setup.

Regards.

I have the same setup/error with MariaDB and using a weak pass is not an option.

Does anyone have a solution for this?

[Edit] Forgot to mention, but owncloud successfully runs on this configuration with a strong password. So it may be something wrong in the NC installer.

Hello, Any solutions yet to this issue? I believe is a bug.
I have never had a MySQL connect issue until now (Nextcloud 10.0.1) in my sql server I also host an Owncloud 8, several wordpress and a Piwik instance. And as I say, I always connect flawlessly to that DB. I tried the Wizard and the Manual install in CLI, same result. I also tried different passwords (weak and strong), same result. I tried using root user and a different user, didn’t work. I tried using a local mysql server (the former one is in another host) didn’t worked also. So… guess it’s a bug.

I’m using:
CentOS 7
PHP 5.4.16
MariaDB Ver 15.1 Distrib 5.5.44
Apache 2.4.6

You perhaps start to mix up different database problems. In case you suspect a real bug, please open a bug report and fill out the template as good as you can. Make sure that you run the latest version (9.0.54 or 10.0.1).

I would proceed as follows:

  • put Nextcloud in maintenance mode
  • change db-password
  • update password in config/config.php
  • switch maintenance mode off

If that is not enough, try to restart the webserver in case the password is cached somewhere. If it still doesn’t work, please open a bug report on github.com/nextcloud/server/issues

can you reproduce that with NC 10.0.1? -> bug report.