My ISP Blocks Port 80 FreeNas How to change the ports

Dear All,

I am new to FreeNas, freebds and Nextcloud . I followed online tutorials on how to install and run nextcloud on freenas. it works from within my network . Now i want to access files remotely via ddns service, but my ISP blocks port 80 and Port 443 . Is there a simple way to teach me how to change such ports . I tried to edit the nextcloud config.php but there is are is no ports there . can someone help

Regards and thank you in Advance

At first, port 80/tcp is usually only required if you want to use and update a Let’s Encrypt certificate for your server automatically. Due to the fact that your isp blocks this port you can disable it by default because you cannot use that mechanism.

I recommend to set-up a port forwarding on your internet router which redirects, e.g. the external port 11443/tcp to your local port 443/tcp. Once you’ve set-up this port forwarding you can easily access your Nextcloud server by appending the port to the url, e.g. “https://your-domain:11443/”.

1 Like