Music app on Nextcloud 10

Hello, I just migrated to nextcloud 10 from owncloud (actually using NC9 in the middle of the migration). Anyway, I noticed I can’t find the “music” app on the appstore anymore, like I used to do when I was using owncloud.
Is this an expected behaviour? Was the app migrated to the new codebase? Is there anything I should do?

Thanks in advance

Yes, b/c the app isn’t approved at this time and in an experimental state.

You have to add the following line to your config.php file:

'appstore.experimental.enabled' => true,

You can change this directly on the Apps page by enabling the setting “Enable experimental apps”.

Thank you very much. It seems to work now :slight_smile:

Is there a way I could follow the development of this app?

BTW you might want to try the “Audio Player” app - it seems much better and is under active development right now. Playlists, one-click play from Files app, Cover flow. It should also be under your experimental apps in the Multimedia section.

Here’s the github repository as well: https://github.com/Rello/audioplayer

Different apps with different concepts.
Music is under active development, too.

Ah I did see last Music commit was only 3 days ago did not notice that originally. Having more than one option is good! :slight_smile:

I’ll try to give a look at this audio player, which seems promising as well :slight_smile:

Anyway, may I ask why the music repo was not migrated to the nextcloud one, just like (I guess) the most of the others?

I try this way but nothing happens in my owncloud i can’t install the music app.

Changed the line in the confg.php -> nothing happens
restart apache2 -> nothing happens

BTW i cant find the point how i can configure the app store in the gui to the experimental Channel.

Hmpf Argl i found it -> forget my post … :slight_smile:

For all guys how are so blind as me :slight_smile: Administration -> Update-Channel change to beta and you will see a lot of apps more

When you are within the app-store click the settings-wheel on the left lower corner and activate the “experimental” there.

Audio Player was requested for an official approval already to get out of "exp."
Still waiting for the go. Until then, its signed and integrity checked already so you dont need to disable these in config

Thanks i found the damm check-box :slight_smile:

Music != Audio Player