Moving from armhf (32bit) to arm64 (Pi 4)

blond me… did that as well… :slight_smile:

1 Like

would you guys mind, if i’d move this to the Howto-category and make the starting post a Wiki?

great, thanks, that’s what I was going to ask for.

you might wanna do the rest

What do you mean? Rewrite the first post? Or start a whole new thread?

@michuvon I mean… Everyone can edit post 1 and the other one now… As they are Wikis

well, I think it’s better for the overview to have all in post 1.
I just merged post 1 & 7 into one.

So it will be enough if only that one is a wiki. - thanks.

1 Like

Sorry, I’m not sure what you mean with mountpoint.
What is exactly meant by that and at waht point do I need to set it up?

Do you mean that I need to name the USB drive the same as before?

(sorry might be a dumb question, but as mentioned before, sometimes basic knowledge is missing… hehe…

Mountpoint example: /media/mydrive

sudo mkdir /media/mydrive
sudo mount /dev/sda1 /media/mydrive

Where ncdata will be in /media/mydrive/ncdata

1 Like

Not yet 100% sure if I connect the dots correctly.

Do you mean that I can simply:

  • attatch the ‘old’ datadir drive
  • login with ssh
  • create a mountpoint
  • run nc-scan
  • load the configs using nc-import
  • done?

No need for nc-restore of the bkp needed?

Without nc-restore, You would miss users, so unless you have only 1 or two users, and recreate them manually.
Nc-restore will do that for you, when restoring the database, after which it will run nc-scan also.
The database will be rebuild/checked by nc-scan.

A (Linux) mointpoint is usually created at /media or /mnt, as in my example above
It is where external drives are connected to the system.

After my first successful restoring of a backup I have learned a lot and edited this wiki as well. I’m now 90% sure that this should work as it is now.

If you have a Pi 4 with the armhf (32bit) image consider testing this “how-to” and give feedback. The worst that can happen is that you need to restore the full backup.

1 Like

Well, I had some time to try my tutorial.
(I did it in my own test envirement, ethernet directly to my Mac, so I don’t have internet and also can not use the web pannel for some reason…)

Anyway, I succeeded, and changed the 32bit image on the SD card with the arm64 image, restored settings, users and apps with nc-import-ncp & nc-restore (dataless backup).

As mentioned by @OliverV nc-scan is done automatically, so no need for that. I also did not do a nc-fix-permissions, but it can’t hurt if you do.

I have not tested for more than a few minutes, but all seems to work fine.

As an argument to use this method, restoring a full backup of 420 GB took about 10h. Following this tutorial with the same setup, took roughly 30min (19min of it to do the nc-scan).

Only there is one strange error when it was finished.

Does someone know that this is and if I need to do something?

Has anyone tried this with server side encryption enabled?

I did it step by step like this and everything worked wonderfully. Thanks for that!

I am using a RP4 with 8GB RAM, runs flawlessly.

Now finally Collabora Online works for editing Office documents in the cloud.

I am very grateful to you for this!
MERCI! :kissing_heart:


Thanks for the feedback, very encouraging to know that this has been useful to others.

First of all, thank you for your tutorial
after restoring my ncp-config_XXXXXXXX.tar
I have no access to my nextcloudpi (https://192.168.1.***:4443/) page or ssh access

Can you help me to find the solution please

Note: I have followed all the steps in the tutorial

I have access to the nextcloud page (https://192.168.1.***/index.php/apps/dashboard/#/), with the ncp account

I did the update from ssh
here is the result

Running nc-import-ncp
Running nc-automount
automount enabled
Running SSH
New password: Retype new password: No password has been supplied.
New password: Password change has been aborted.
passwd: Authentication token manipulation error
passwd: password unchanged
file  not found
Running unattended-upgrades
Unattended upgrades active: yes (autoreboot true)
Running nc-webui
Site ncp disabled.
To activate the new configuration, you need to run:
  systemctl reload apache2
ncp-web disabled
Running nc-previews-auto
Automatic preview generation enabled
Running nc-httpsonly
Forcing HTTPS On
Running nc-notify-updates
update web notifications enabled
Running nc-backup-auto
automatic backups enabled

configuration restored

Sorry for not reacting, I’m back online after a long time.

so, you still don’t have access to the ncp web panel?

can you make sure that the web panel is enabled in the ncp-config settings (command line)sudo ncp-config
it’s somewhere in the settings, not sure where exactly.

I’ll look at it the next time I try to do the migration.
Now I can’t


On my current nextcloudpi which I have not updated, I have access to sudo ncp-config from the terminal with no problems and web panel is enabled

Sorry I did not read well your first post and did not realise that you also don’t have access to ssh.

what about if you don’t restore the config, but only the backup, is it still not working?

Honestly speaking I’m probably as helpless as you are.

I’ll try again in a while, then I’ll give you news again here