Modifying Groups for you own user

Hi everyone!

I’m struuggling with this simple issue: managing my groups.
The only way I found to change them is to log in as a different, privileged user and from there there is no problem. But maybe I’m missing something really simple…

Thanks, have a nice day!

hmm this seems to be a bug of the last few versions (18.0.3 still has this bug)

to be sure that it really is a bug we would need more infos from you…
like the template asked for that you deleted…
so what exactly did you try? how? where?
pls give out some more infos about your setting, involved softwares, envorinment, logs, etc…

Hi Jimmy, thanks for taking time to answer!

Actually it’s really simple: in NC 18.0.x just try to modify the groups you’re in. Are you able to to it?

I, as admin, see the pencil icon beside every user in the user list ( /index.php/settings/users ) except beside my account, so the only way I found is to log out and in again as a different, privileged user.


as a normal user you shouldn’t be granted any rights to modify any group you’re in. that should be possible only for group- and general admins, only.

i have removed the concept of having groupadmins within my small installation because it was buggy (couldn’t access any setup page of those accounts anymore unless groupadmin-priviledge was removed again)

Sure, but also as admin, I’m not able to modify my groups!

welll right now - as handling of sql-entries was completely new written for nc18 - there seems to be a general problem with modifying your own account… in general…
this would mark being a known bug…

ok, anyway I solved the problem making a login with a different. admi-privileged account


1 Like

Same thing observerd with last version 18.0.3. Logged as a super admin. Not possible to change my own groups.

wait for 18.0.4

Thanks Jimmy!

1 Like

Hi Jimmi, I’ve just installed NC19, and still no possibility to change my own groups (as admin).

Thanks for your time, cheers!

well i haven’t followed the github discussion… and thus i dunno where exactly they got stuck so far. but nc19 is still beta… meaning some apps still need some rework and furbishing… so maybe it’s gonna happen until the golden master