Missing index "cards_abiduri" in table "oc_cards"

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

I’m on a Bluehost shared hosting plan.

I get this warning Missing index “cards_abiduri” in table “oc_cards”. Is there a way to run a MySQL query to create the index?

Nextcloud version (eg, 20.0.5): 20.0.5
Operating system and version (eg, Ubuntu 20.04): Ubuntu 20.04
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.46
PHP version (eg, 7.4): 7.4.14

The issue you are facing:
Admin states Missing index “cards_abiduri” in table “oc_cards”.

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. Select Administration / Overview Security & setup warnings

The output of your Nextcloud log in Admin > Logging:

Nothing relevant

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'portal.borghoff.com',
  'datadirectory' => '/home1/borghoff/public_html/portal/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://portal.borghoff.com',
  'dbname' => '',
  'dbhost' => '',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '',
  'dbpassword' => '',
  'installed' => true,
  'maintenance' => false,
  'updater.secret' => '',
  'mail_from_address' => '',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '',
  'mail_smtpport' => '',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpname' => '',
  'mail_smtppassword' => '',

The output of your Apache/nginx/system log in /var/log/____:

No access

Hey Jeff and welcome to the user-forums of NC.

first of all: NC wasn’t meant to be used on a shared hosting service… Since they usuallly restrict the usage of resources and make it very difficult to access commandline etc. So do YOU have access to your commandline?

If not try to enable app WebOCC (or such, could be OCCWeb as well) from Appstore. Most prolly it’ll tell you that it isn’t meant for be used with NC20. Try to enable it though as I have read (on the forums) that it might work as desired though.

After that you should be able to execute command occ db:add_missing_tables (or indices, the manual will tell you the exact command) which should solve your problem.

And last but not least: It’s considered polite if you’d search the forum for similar postings before opening a new thread.

Good luck

Thank you @JimmyKater. I will try WebOCC, thank you. I did search beforehand indeed.


1 Like