Missing app store!

After updating from some old install (like 14-15) to the latest I think I’m not missing the app store. I can open +Apps but it only shows me the list of installed, enabled, disabled apps with no way to search and install new ones.

Is it moved somewhere?

Probably not. I checked the Missing app store thread here as well as some others, there’s nothing related to appstore in my config.json (and never was), and I tried removing apps.json and some other entries as suggested in solutions from those threads from the database oc_filecache, nothing changed.

So, can someone, please, help me solve the issue?

It also says this in the overview :

Nextcloud 17.0.1

A new version is available: Nextcloud 15.0.12
Could not connect to the appstore or the appstore returned no updates at all. Search manually for updates or make sure your server has access to the internet and can connect to the appstore.

Though config.php show 17.0.1

But I’ve found this in the database:

{"version":"15.0.12.1","versionstring":"Nextcloud 15.0.12","url":"https:\/\/download.nextcloud.com\/server\/releases\/nextcloud-15.0.12.zip","web":"https:\/\/docs.nextcloud.com\/server\/15\/admin_manual\/maintenance\/upgrade.html","changes":"https:\/\/updates.nextcloud.com\/changelog_server\/?version=15.0.12","autoupdater":"1","eol":"0"}

What should it look like for 17.0.1 ?

Ah, this may be the issue

This server has no working Internet connection: Multiple endpoints could not be reached. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. Establish a connection from this server to the Internet to enjoy all features.

I wonder why it can’t reach those endpoints. What endpoints are those? Maybe they are just blocked?

Solved. I had ‘proxy’ parameter in my config.php file, which I used by mistake instead of ‘trusted_proxies’. Removing that and replacing it with trusted proxies solved the issue.