MIME type checking error only on Apps page after upgrading to 18.0.1

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2):
Operating system and version (eg, Ubuntu 17.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:
After upgrading to Nextcloud 18.0.1 from 17.X; my Apps page doesnt open due to an error

Refused to execute script from ‘https://cloud.xxx.com.tr/apps/files/’ because its MIME type (‘text/html’) is not executable, and strict MIME type checking is enabled.

Well, all the apps are running and Nextcloud is fine. It’s just the apps page. I also did chown-R www-data:www-data to all nextcloud folder.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Upgrade from 17.X to 18.0.1

The output of your Nextcloud log in Admin > Logging:

Nothing about this issue. It's currently crowded with Errors I encountered while moving the apps folder around.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'log_type' => 'file',
  'logfile' => '/var/log/nextcloud.log',
  'logfilemode' => 416,
  'loglevel' => 2,
  'logdateformat' => 'F d, Y H:i:s',
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'cloud.xxx.com.tr',
  ),
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '18.0.1.3',
  'overwrite.cli.url' => 'https://cloud.xxx.com.tr',
  'dbname' => '',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'next',
  'dbpassword' => '',
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'filelocking.enabled' => 'true',
  'memcache.locking' => '\\OC\\Memcache\\Redis',
  'simpleSignUpLink.shown' => false,
  'redis' => 
  array (
    'host' => 'localhost',
    'port' => 6379,
    'timeout' => 0.0,
    'password' => '',
  ),
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_from_address' => 'no-reply',
  'mail_domain' => '',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtphost' => 'smtp.yandex.com',
  'mail_smtpauth' => 1,
  'mail_smtpport' => '465',
  'mail_smtpname' => '',
  'mail_smtppassword' => '',
  'maintenance' => false,
  'theme' => '',
  'mysql.utf8mb4' => true,
  'apps_paths' => array (
    0 =>  array (
      'path' => '/var/www/nextcloud/apps',        # base apps
      'url' => '/apps',
      'writable' => false,
    ),
    1 => array (
      'path' => '/var/www/nextcloud/apps2',       # 3rd-party apps
      'url' => '/apps2',
      'writable' => true,
    ),
  ),
);

The output of your Apache/nginx/system log in /var/log/____:

Nothing about Nextcloud.

It got fixed “magically”.

I did nothing.