Migration problems to 28.0.1 version

Hi colleagues.
I need some advice. I have two servers, old nextcloud 23.0.8 and new 28.0.1.
I’m doing a migration, I’ve prepared everything, backed up the database on the old server and moved it to the new one, at startup the system says to upgrade. I started the process:
sudo -u www-data php occ upgrade
But then I got an error.


I tried to find this value to delete it using queries, but it didn’t work, does anyone know what to do?
Searching the catalogue in Linux is not found either…

SELECT * FROM user_ldap_membership_unique WHERE uuid LIKE ‘nextcloud-1BEFCC54-1D87-4500-9681-78C636F14B44’;

SELECT CONCAT('SELECT * FROM ‘, table_schema, ‘.’, table_name,’ WHERE ‘, column_name, ’ LIKE "%’, ‘nextcloud-1BEFCC54-1D87-4500-9681-78C636F14B44’, ‘%" LIMIT 1;’) AS query
FROM information_schema.columns
WHERE table_schema = ‘nexcloud’ AND data_type IN (‘char’, ‘varchar’, ‘text’, ‘mediumtext’, ‘longtext’);

Check these two Issues and see if one of them is applicable to you. You may be able to find a resolution there or help find one[1][2].

[1] [Bug]: Upgrade fails - app user_ldap update failed `SQLSTATE[23000]: Integrity constraint violation` · Issue #42232 · nextcloud/server · GitHub
[2] [Bug]: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'NextCloud-da0f4174-c707-103c-89a4-dfb392a94239' for key 'user_ldap_membership_unique' · Issue #42482 · nextcloud/server · GitHub

2 Likes

Hi thank you, I reinstall full the server and nextcloud, now the error is gone