Migrating from OC 9.1.5 to NC 11.0.3 (File Sharing Plugins Error)


I have tried to migrate from OC 9.1.5 to NC 10.0.5 manually by following tutorial in here.

The migration had no errors, however when i tried logging in with user account there are error like this:

Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

Technical details
Remote Address: x.x.x.x
Request ID: 2ii9UoV6Qyj9EswHLpDz

But when the file sharing plugins turned off, the user can log in.

Then i tried to update manually with occ to NC 11.0.3 and the problem still exist.

The error logging from Nextcloud admin page is like this:

InvalidArgumentException: Invalid recipient
/var/www/nextcloud/apps/files_sharing/lib/MountProvider.php - line 173: OC\Share20\Manager->moveShare(Object(OC\Share20\Share), ‘24818BA2-F065-4…’)
/var/www/nextcloud/apps/files_sharing/lib/MountProvider.php - line 78: OCA\Files_Sharing\MountProvider->buildSuperShares(Array, Object(OC\User\User))
/var/www/nextcloud/lib/private/Files/Config/MountProviderCollection.php - line 77: OCA\Files_Sharing\MountProvider->getMountsForUser(Object(OC\User\User), Object(OC\Files\Storage\StorageFactory))
[internal function] OC\Files\Config\MountProviderCollection->OC\Files\Config{closure}(Object(OCA\Files_Sharing\MountProvider))
/var/www/nextcloud/lib/private/Files/Config/MountProviderCollection.php - line 78: array_map(Object(Closure), Array)
/var/www/nextcloud/lib/private/Files/Filesystem.php - line 446: OC\Files\Config\MountProviderCollection->getMountsForUser(Object(OC\User\User))
/var/www/nextcloud/lib/private/Files/Filesystem.php - line 375: OC\Files\Filesystem initMountPoints(‘24818BA2-F065-4…’)
/var/www/nextcloud/lib/private/legacy/util.php - line 235: OC\Files\Filesystem init(‘24818BA2-F065-4…’, ‘/24818BA2-F065-…’)
/var/www/nextcloud/lib/base.php - line 1009: OC_Util setupFS()
/var/www/nextcloud/index.php - line 40: OC handleRequest()

Any help is appreciated.
Thank you.

Nevermind, i have tried to update it to Nextcloud 12.0 using this tutorial and it works!