Memchace APCu not applying [SOLVED]

Nextcloud version: 15.0.7
Operating system and version: Fedora 29
Apache or nginx version: nginx 1.16.0
PHP version: 7.3.5

The issue you are facing:
I get the error: " The PHP OPcache module is not loaded. For better performance it is recommended to load it into your PHP installation."

I have installed APCu memcach using dnf install php-pecl-apcu and have put 'memcache.local' => '\OC\Memcache\APCu', in my config.php in the nextcloud directory.
I have also changed apc.enable_cli to 1 in /etc/php.d/40-apcu.ini and restarted both php-fpm and nginx.

I have tried escaping the slashes like 'memcache.local' => '\\OC\\Memcache\\APCu',, but that does nothing either.

Is this the first time you’ve seen this error? (Y/N): Yes, it worked on my previous server.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'log_type' => 'syslog',
  'datadirectory' => '/var/www/nextclouddata',
  'updatechecker' => false,
  'check_for_working_htaccess' => false,
  'asset-pipeline.enabled' => false,
  'assetdirectory' => '/var/www/nextcloud',
  'memcache.local' => '\OC\Memcache\APCu',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/var/www/nextcloud/apps',
      'url' => '/apps',
      'writable' => true,
    1 => 
    array (
      'path' => '/var/www/nextcloud/apps',
      'url' => '/apps-appstore',
      'writable' => true,
  'instanceid' => '[CENSORED]',
  'passwordsalt' => '[CENSORED]',
  'secret' => '[CENSORED]',
  'trusted_domains' => 
  array (
    0 => '[CENSORED]',
  'overwrite.cli.url' => '[CENSORED]',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => '[CENSORED]',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => '[CENSORED]',
  'dbpassword' => '[CENSORED]',
  'logtimezone' => 'UTC',
  'installed' => true,
  'theme' => '',
  'loglevel' => 2,
  'maintenance' => false,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'twofactor_enforced' => 'false',
  'twofactor_enforced_groups' =>    
  array (
  'twofactor_enforced_excluded_groups' => 
  array (
  'data-fingerprint' => '[CENSORED]',

Does anyone happen to know how to make sure APCu memcaching gets applied so the warning goes away?

PHP OPcache and Memcache like APCu are different things, OPcache creates usable “Bytecode” of the PHP files for faster execution, APCu caches user objects which therefor do not need to be loaded from disk or database.

See their manuals for further information:

I am aware that they are different things. The documentation is clear about this. My confusion is that I might get the warning because no memcache is configured at all. I did not see this on my other server that also did not have OPCache, which I described in my initial post.

So do you think APCu cache is configured properly and this message is a bug or do you think APCu is not applying?

The documentation says “Refresh your Nextcloud admin page, and the cache warning should disappear.” which does not appear to happen.

You posted a warning about PHP OPcache and enabled APCu. This was the point i was responding to. The OPCache warning will not go away unless you enable OPcache. To enable OPcache follow the instructions on the PHP docs.

That clears things up, thank you for your help. Looks like I misunderstood both you and the docs.