Memcache Setup & remove index.php

Nextcloud version: 12.0.4
Operating system and version: CentOS 7
Apache or nginx version: Apache
PHP version: 7.0
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps):

The issue you are facing:
Added the rules to remove index.php from the URL, and I can see the changes made it to .htaccess, but it’s not working. And yes, mod_rewrite is working. View the full .htaccess here:

I’ve also tried enabling the memcache, but in doing so, I get a 503 error in trying to utilize it. I’m pretty sure I’ve just set it up wrong, but the setup guides aren’t exactly clear either. APCu isn’t installed, which is the most likely candidate. However, using yum to search for available packages, there are no packages with “apcu” in the name.

'memcache.local' => '\OC\Memcache\APCu',
  'memcache.distributed' => '\OC\Memcache\Memcached',
  'memcached_servers' => array(
        array('localhost', 11211),

The output of your Nextcloud log in Admin > Logging:

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

About pretty URLs: Due to browser caching etc it can take a while until you see the effect. You can force the trial by just removing the /index.php from any nextcloud URL in address field manually.

About caching: memcached is just for distributed caching, you need this? Set eather redis or APCu for local caching. Both packages are not available in you repo? Which repo you use to get php7 on centos?

When I forcefully remove index.php from the URL, NC forcefully puts it back in the URL.

As for repos, these are the ones being searched when trying to use yum

I was able to possibly have installed apcu though following this, but I wasn’t able to find the configuration:

APCu is installed, but when I try to enable memcaching with APCu for local, I get this error:

Module ‘apcu’ already loaded at Unknown#0
OC\HintException: Memcache \OC\Memcache\Memcached not available for distributed cache at /mnt/mma/mma/public_html/subdomains/cloud/lib/private/Memcache/Factory.php#111