Meaning of Error Message received when setting up NextCloud

I’m trying to setup NextCloud server on my shared hosting service (i.e., called Bluehost) by using the “Web Installer”. In the process, I encountered an error message but need some help understanding what it means. Error is shown in the image the follows:

Bluehost offers you a 24/7-Support. So why not call the Support-Team.

Yes, I intend to do that but their system is cumbersome from the user perspective and takes quite a bit of time even for a simple question. I’ll have more time available starting tomorrow.

However, I have what might be a simpler question. When it comes to the database, I’ve assumed that this so called quick approach is going to create a database using the parameters I’ve specified. Could it be that I am supposed to have created the database before running this procedure?

It seemed like there was nothing to loose so why not give it a try. I went ahead and created the database on my hosting service. Then deleted all the previously created files and started over. The installer finished running without any errors. In that, problem solved. However, I would add that I was not aware of any mention in the documentation about the need for me to create the database before running the installer. It might be a good idea to update the documentation to make that clear.

Of course I still have to get it connected to my devices but whatever problems develop with that would be considered different from this one. I do suspect that compatibility with my hosting service is anything but certain at this point.

If the db credentials you specify have sufficient privileges, it will.

See Installation Wizard section of the Admin Manual (though perhaps it could be clearer):

In this case I was signed on to my hosting service and the installer was being run on my hosting service. It is my hosting service credentials that enable a database (DB) to be created on my hosting service. The credentials entered in the installation wizard were/are those to be used for accessing the database once it is created. However, when the error associated with the post occurred the DB had not yet been created. I was expecting the wizard to do that. Everything appeared, to me, to work fine when I opted to create the DB before running the wizard. Note: creating a MySQL database does not cause any data to be stored in it. I think it would be fair to say that only establishes the credentials needed to run the SQL commands involved adding table structure and data to the DB.