Mastercontainer takes hours to get past 'Adding internal www-data to group ping' after a restart

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 29.0.5): 28.0.6
Operating system and version (eg, Ubuntu 29.04): Ubuntu 22.04
Apache or nginx version (eg, Apache 2.4.25): Nginx
PHP version (eg, 8.3): AIO 8.3.0

The issue you are facing:
Any time the master container is restarted, it takes hours before the master container is ready to start hosting my instance again. The logs just show the following:

‘’’
[+] Running 2/2
:heavy_check_mark: Network opt_default Created 0.7s
:heavy_check_mark: Container nextcloud-aio-mastercontainer Started 12.3s
nextcloud-aio-mastercontainer | Trying to fix docker.sock permissions internally…
nextcloud-aio-mastercontainer | Adding internal www-data to group ping
‘’’

Is this the first time you’ve seen this error? No:

Steps to replicate it:

  1. Stop all running containers
  2. Stop the Master Container
  3. Restart the Master Container (doesn’t matter if it gets updated or not)
  4. Docker compose logs -f just shows the above for 4-6 hours before it moves on and launches the AIO interface

I doubt it’s getting truly stuck in the group add, but there’s a ton of stuff that executes after that which may not generate output.

Two things:

  • Do you have any warnings or errors under Administration settings->Overview?
  • Please share your Compose file

Yes, there are a ton of warnings and some errors, nothing that appears to take terribly long, though. Most of the log is suspicious_login from my Davx5 connection and then some errors during what I assume to be the container update portion that look like this:

From start of the master container to when I can access the AIO page was about 4.5 hours for reference.

Here is my docker compose file:

---
services:
  nextcloud:
    image: nextcloud/all-in-one:latest
    restart: unless-stopped
    container_name: nextcloud-aio-mastercontainer
    volumes:
      - nextcloud_aio_mastercontainer:/mnt/docker-aio-config
      - /var/run/docker.sock:/var/run/docker.sock:ro
    ports:
      - 8080:8080
    environment:
      - APACHE_PORT=11000
      - NEXTCLOUD_DATADIR=/mnt/ncdata
      - APACHE_IP_BINDING=0.0.0.0
      - SKIP_DOMAIN_VALIDATION=true
      - NEXTCLOUD_UPLOAD_LIMIT=100G
      - NEXTCLOUD_MAX_TIME=7200
      - NEXTCLOUD_MEMORY_LIMIT=1024M
volumes:
  nextcloud_aio_mastercontainer:
    name: nextcloud_aio_mastercontainer
    driver_opts:
      type: nfs
      o: addr=xxx,nolock,hard,rw
      device: :/mnt/tank/appdata/p-nextcloud

Can you share a bit more about your NFS volume? For example, what NFS implementation? And any particular reason you are using nolock?

1 Like

It is NFSv3, which connects to a Supermicro NAS on my network running Ubuntu. No particular reason for nolock, I was just following other example setups I’ve seen.

Let me know if you need any other additional info on the NFS mount.