Masked ip cant acces nextcloud

Hello i’m self hosting nextcloud under an ip but i would like it to be hidden - I brought domain on porkbun - normal forwarding works like a charm but when I added mask to the forwarding and refreshed site it just says err_connection_refused
i’v added domain in question to trusted domains. Any idea what would be the problem ?

I’m hosting nextcloud on proxmox server ubuntu server nc installed with snap.

what do you mean by that? Is this some internal proxy?

I mean this function wich should ( and in most cases) mask ip in the adress bar so to not show my own ip adress.
but when i use this function nextcloud refuses connection it works really good on direct ip:port connection but i want a hiden redirect from domain.
and i dont know/understand what i need to change add for it work.

i asked on porkbun support issue is on going but i really do think its a nextcloud settings issue.

There are some security concern why it is generally not possible to run Nextcloud within a frame. For that reason the “masked” option is not working. However, you can still check the address of a frame, so it won’t really hide the IP.

If that is your domain, I would just resolve the DNS to your IP so you can just use the regular domain name. If you want to hide your IP, you’ll need a proper proxy service…