MariaDB / InnoDB Problem

Hi together.

I had a NextCloudPi running for a few month. But now it is not working anymore. It says that the MariaDB is not running anymore.

Running nc-info
Gathering information...
NextCloudPi version  v1.28.1
NextCloudPi image    NextCloudPi_03-28-20
distribution         Raspbian GNU/Linux 10 \n \l
automount            yes
USB devices          sda
datadir              /media/WD
data in SD           no
data filesystem      btrfs
data disk usage      733G/7.3T
rootfs usage         3.9G/15G
swapfile             /var/swap
dbdir                /var/lib/mysql
Nextcloud check      error
HTTPD service        up
PHP service          up
MariaDB service      down
Redis service        up
Postfix service      up
internet check       ok
port check 80        open
port check 443       open
IP                   ***
interface            eth0
certificates         ***
NAT loopback         no
uptime               2:51

The mysql error log says

2020-08-24 18:40:05 0 [Warning] InnoDB: Retry attempts for reading partial data failed.
2020-08-24 18:40:05 0 [ERROR] InnoDB: Tried to read 16384 bytes at offset 6291456, but was only able to read 0
2020-08-24 18:40:05 0 [ERROR] InnoDB: Operating system error number 5 in a file operation.
2020-08-24 18:40:05 0 [ERROR] InnoDB: Error number 5 means 'Input/output error'
2020-08-24 18:40:05 0 [Note] InnoDB: Some operating system error numbers are described at
2020-08-24 18:40:05 0 [ERROR] InnoDB: File (unknown): 'read' returned OS error 205. Cannot continue operation
200824 18:40:05 [ERROR] mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.

To report this bug, see

We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

Server version: 10.3.22-MariaDB-0+deb10u1
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 466218 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0x0 thread_stack 0x49000
The manual page at contains
information that should help you find out what is causing the crash.
Writing a core file...
Working directory at /var/lib/mysql
Resource Limits:
Limit                     Soft Limit           Hard Limit           Units
Max cpu time              unlimited            unlimited            seconds
Max file size             unlimited            unlimited            bytes
Max data size             unlimited            unlimited            bytes
Max stack size            8388608              unlimited            bytes
Max core file size        0                    unlimited            bytes
Max resident set          unlimited            unlimited            bytes
Max processes             29184                29184                processes
Max open files            16364                16364                files
Max locked memory         65536                65536                bytes
Max address space         unlimited            unlimited            bytes
Max file locks            unlimited            unlimited            locks
Max pending signals       29184                29184                signals
Max msgqueue size         819200               819200               bytes
Max nice priority         0                    0
Max realtime priority     0                    0
Max realtime timeout      unlimited            unlimited            us
Core pattern: core
sudo nc-update devel

At least that solved it for me; is it an 8GB Pi?

Did not help. 4GB. Am I out of RAM when starting database?

It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 466218 K bytes of memory
Hope that’s ok; if not, decrease some variables in the equation.

I did some large uploads lately and shutdown mid upload. But seems to just need 466MB right?