Mailbox-Integration with icewarp as mailserver failed

We try to access via mail app an icewarp mail server user mailbox, unfortunatley not successfully.

We tried to do the same with the thunderbird client, to get more details about the connection. With this client we could connect.

In the thunderbird client we had to choose the “authentication method” “Encryted password” to connect successfully.

How could we do this in the NC-Mailapp.
Should we maybe encrypt the password? Which method is used for this.

Thanks for a tipp or advice
Moritz

– Some printscreens to the mail app config and thunderbird-
Mail-App-Config:

NC-Log
{“reqId”:“oIPLoJzgAlojkpYVKw93”,“level”:3,“time”:“2020-12-15T15:34:19+00:00”,“remoteAddr”:“10.0.0.2”,“user”:“Moritz”,“app”:“mail”,“method”:“POST”,“url”:"/apps/mail/api/accounts",“message”:“Creating account failed: Could not connect to IMAP host mailsrv1.changeme.com:143: Could not open secure TLS connection to the IMAP server.”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.88 Safari/537.36 Edg/87.0.664.60”,“version”:“20.0.3.2”,“id”:“5fd8d77c5eac1”}

Thunderbird-Printscreen of the successfully connection

IMAP-Config:

SMTP-Config
image

I would interpret this message as if the app has problems to establish a secure connection and not that an authentication failure has happened, which would be the next step in the connection process. Therefore I recommend to follow the instructions given in the following posting to get a more detailed debug log:

I think you are looking for https://github.com/nextcloud/mail/issues/3146

Unfortunatley the link https://docs.nextcloud.com/server/stable/developer_manual/general/devenv.html#enabling-debug-mode does not work :frowning:.
I found
mail/admin.md at master · nextcloud/mail (github.com), etc.

level to debug in config.php we already have done it to 0 =DEBUG

Found solution: Mail App does not work with TLS on SMTP and IMAP - :bento: Features & apps / :love_letter: Mail - Nextcloud community

Missing peace was:

in config.php the parameter: app.mail.verify-tls-peer = false

Thanks

https://docs.nextcloud.com/server/stable/developer_manual/getting_started/devenv.html#enabling-debug-mode is the one