Mail settings not working

Smtp settings within NC 29 dont work anymore

{“reqId”:“Bep8s031UbIGYruhB5q7”,“level”:0,“time”:“2024-06-03T09:12:26+02:00”,“remoteAddr”:“192.168.2.94”,“user”:“beheer”,“app”:“core”,“method”:“POST”,“url”:“/settings/admin/mailtest”,“message”:“Sending mail to "Array\n(\n [info@] => info@\n)\n" with subject "E-mailinstellingen test" failed”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/125.0.0.0 Safari/537.36 Edg/125.0.0.0”,“version”:“29.0.1.1”,“exception”:{“Exception”:“Symfony\Component\Mailer\Exception\TransportException”,“Message”:“Connection could not be established with host "ssl://webmail.servicenet.nl:25": stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages:\nerror:0A00010B:SSL routines::wrong version number”,“Code”:0,“Trace”:[{“function”:“Symfony\Component\Mailer\Transport\Smtp\Stream\{closure}”,“class”:“Symfony\Component\Mailer\Transport\Smtp\Stream\SocketStream”,“type”:“->”,“args”:[“*** sensitive parameters replaced “]},{“file”:”/var/www/nextcloud/3rdparty/symfony/mailer/Transport/Smtp/Stream/SocketStream.php",“line”:157,“function”:“stream_socket_client”},{“file”:“/var/www/nextcloud/3rdparty/symfony/mailer/Transport/Smtp/SmtpTransport.php”,“line”:251,“function”:“initialize”,“class”:“Symfony\Component\Mailer\Transport\Smtp\Stream\SocketStream”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/symfony/mailer/Transport/Smtp/SmtpTransport.php”,“line”:194,“function”:“start”,“class”:“Symfony\Component\Mailer\Transport\Smtp\SmtpTransport”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/symfony/mailer/Transport/AbstractTransport.php”,“line”:72,“function”:“doSend”,“class”:“Symfony\Component\Mailer\Transport\Smtp\SmtpTransport”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/symfony/mailer/Transport/Smtp/SmtpTransport.php”,“line”:136,“function”:“send”,“class”:“Symfony\Component\Mailer\Transport\AbstractTransport”,“type”:“->”},{“file”:“/var/www/nextcloud/3rdparty/symfony/mailer/Mailer.php”,“line”:45,“function”:“send”,“class”:“Symfony\Component\Mailer\Transport\Smtp\SmtpTransport”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Mail/Mailer.php”,“line”:196,“function”:“send”,“class”:“Symfony\Component\Mailer\Mailer”,“type”:“->”},{“file”:“/var/www/nextcloud/apps/settings/lib/Controller/MailSettingsController.php”,“line”:168,“function”:“send”,“class”:“OC\Mail\Mailer”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php”,“line”:232,“function”:“sendTestMail”,“class”:“OCA\Settings\Controller\MailSettingsController”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php”,“line”:138,“function”:“executeController”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/AppFramework/App.php”,“line”:184,“function”:“dispatch”,“class”:“OC\AppFramework\Http\Dispatcher”,“type”:“->”},{“file”:“/var/www/nextcloud/lib/private/Route/Router.php”,“line”:338,“function”:“main”,“class”:“OC\AppFramework\App”,“type”:“::”},{“file”:“/var/www/nextcloud/lib/base.php”,“line”:1050,“function”:“match”,“class”:“OC\Route\Router”,“type”:“->”},{“file”:“/var/www/nextcloud/index.php”,“line”:49,“function”:“handleRequest”,“class”:“OC”,“type”:“::”}],“File”:“/var/www/nextcloud/3rdparty/symfony/mailer/Transport/Smtp/Stream/SocketStream.php”,“Line”:154,“message”:"Sending mail to "Array\n(\n [info@] => info@\n)\n" with subject "E-mailinstellingen test" failed",“exception”:[],“CustomMessage”:"Sending mail to "Array\n(\n [info@] => info@***\n)\n" with subject "E-mailinstellingen test" failed”},“id”:“665d6cdde0626”}

{“reqId”:“mgGQaQDySp9REfrdn1uC”,“level”:0,“time”:“2024-06-03T09:17:13+02:00”,“remoteAddr”:“192.***”,“user”:“beheer”,“app”:“no app in context”,“method”:“POST”,“url”:“/settings/admin/mailtest”,“message”:“Email transport "Symfony\Component\Mailer\Transport\Smtp\SmtpTransport" stopped”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/125.0.0.0 Safari/537.36 Edg/125.0.0.0”,“version”:“29.0.1.1”,“data”:,“id”:“665d6e03b015b”}

Fix the SSL settings as well as OpenSSL

What version of Nextcloud did you upgrade this same installation from (that you last successfully used SMTP in)?

Also:

SSL issue fixed

2 Likes

Can you please tell us, where exactly was the error and how you did fix it? - It might help other users, who run into the same problem.

Thank you in advance.