Mail app not working in RC 10?

Upgraded from ownCloud 9.1 -> RC 10. Notice the Mail app and enabled it. Clicking it, I get spin pinwheels in the main area and the left side which go forever (initial configuration screen never comes up). Anyone else experiencing this? I checked github and couldn’t find a bug report but wondering if anyone else experiencing this.

1 Like

Did you check your logfiles?

I have seen this behavior in the pas with the Mail app, when it was in an early stage of development.

Maybe you can give us some more infromation:

  • open the developer tools in your browser (F12)
  • go to the console tab and see if there are any errors (a screenshot would be good)
  • go to the network tab and see if there are requests which end in status 500 (a screenshot would be good)

You could also try to clear the localStorage in your browser, to do this again open the console tab and run localStorage.clear()

EDIT: I’ll try to install the mail app later today.

So I have tested it on my development VM, (fresh install) and installed Mail and it’s working perfect. (Even faster :slight_smile: )

So it have something to do with the upgrade, I’d really try clearing localstorage.

All requests’ result are 200, note that I am using HTTP2.
And the localStorage.clear() is returning undefined.

I have an Error in the console while loading:
Error: An "el" #mail-new-message-fixed must exist in DOM in mail.min.js:150:0

So, you’re saying it works fine from scratch and my close-to-be-perfect solution was to clean everything (please don’t do that if you don’t know what you’re doing)

- disable Mail
- uninstall Mail
> DELETE FROM oc_appconfig WHERE appid='mail';
> DROP TABLE oc_mail_accounts, oc_mail_collected_addresses;
- enable/install Mail

and it worked.
The value of ‘installed_version’ in oc_appconfig was 0 before I cleaned the value appid=‘mail’. I checked in my dump from 9.0.53 and it was already 0 there. It is now 0.5.2 (the others value are the same before and after the reinstallation of the Mail). Also I tried to put the value of ‘installed_version’ to 0 and the Mail apps was still working.

Also, I don’t have the JS error anymore.

I just tried updating my instance, and have exact the same problem.

I created an issue for this:

Thanks for all this! :slight_smile: tried all suggestions but no go - including after spinning up a new VM and doing a fresh install (no upgrade) - until I checked apps/mail/ and saw the note about INBOX prefixes in Dovecot. I am using Courier-IMAP, which also does indeed use INBOX prefix by default as well… and you cannot configure it not to AFAIK?

After manually renaming the prefixed folders over SSH it did come up OK in Chrome, however only the Inbox with Sent / Drafts / Trash - and also manually created folders underneath it - clicking “Show all folders” or “Collapse all folders” has no effect. It is all there though.

FF 48.0.1 though, still spinning wheels even after running localStorage.clear; in the console. I’ll test this a bit more tomorrow and post further over at the bug report. Thanks again! :smiley: