Mail app: how to turn off slow icon-loading from external servers

i just upgraded to 12.0.5 (everything went fine)
in 12.0.4 i had downgraded the mail-app to 0.7.5 (after an upgrade to 0.7.4) because the icon-loading from external servers (to show lil’ pix and icons in the mail-list) is SLOW, privacy-sensitve and (to me) generally and visually annoying.
see here: old issue
the upgrade to 12.0.5 force-upgraded the mail-app to 0.7.9 again and the issue is here again.
turning off the “feature” in the users’ mail-settings does not work - the “load icons” tick magically reappears every time after it was turned off.
so how can this be turned off?
and if not, is it safe to downgrade the mail app?
(on 12.0.4 the downgrade failed the code integrity check but mail worked flawlessly anyway)
THX for you input!

Hi,

opt-out of external avatars has been added in https://github.com/nextcloud/mail/releases/tag/v0.7.6. Note that already fetched avatars are not removed from the cache, thus they might appear for a little while. As soon as the checkbox is unchecked, no new external avatars are fetched though.

If you still face problems and think there’s a bug, please file it as bug report on GitHub https://github.com/nextcloud/mail/

Downgrades are not supported. If you break anything by downgrading you’ll be on your own.

Thanks

@ChristophWurst:
What do you think about setting this checkbox as default in future versions?

Thank you for your reply!
As I stated above, turning off this setting is not saved; even when i uncheck the box, after i open a different part of nextcloud or log out, the box is checked again the next time.
Is there really no way to turn this off?
(It makes the app so slow that really do not like to use it anymore; also, it raises privacy concerns.)

As stated above

If you still face problems and think there’s a bug, please file it as bug report on GitHub https://github.com/nextcloud/mail/

sorry, i do not have a github-account.
i tested a couple of users and the setting not to fetch imagefiles from external servers for mail-display is just not saved - whenever a user re-opens mail the next time this setting is checked again.
downgrading also seems impossible - i tested, but do not want to endanger an otherwise stable productive configuration.
so how can this feature be deactivated permanently?
THX for your help!

i finally found a simple solution that made the mail app light and fast again and does not contact any servers i do not want to contact:
in the file
[NC-WEBDIR]/apps/mail/lib/Service/Avatar/CompositeAvatarSource.php
i commented out the content or the sources-array so it looks like this:

 $this->sources = [
                /*      $addressbookSource,
                        $gravatarSource,
                        $faviconSource,  */
                ];

(i inserted the /* before $addressbookSource, and the */ after $faviconSource) et voila!

@ChristophWurst
i do not mean to mess up the code you so generously write for us but for me this feature was just not useful and opt-out did never work .

Fix is in https://github.com/nextcloud/mail/pull/776