Mageia 6, Onlyoffice/Collabora Online

Hi. I have server with Mageia Linux 6 (i5, 16 GB DDR3, SSD, Nextcloud 14.0.10). Nextcloud runs great and fast, but I tried to install/enable Onlyoffice and Collabora Online but I cannot open any doc/xls/docx/pps… Could anybody help me, please? On Ubuntu 18.04 LTS works Onlyoffice fine, but only on local interface. If somebody could help me, I will give you IP, root password and everything… There are no files on the server…
Thank you very much…

HI @vollogia,

So the OnlyOffice installation on Ubuntu 18.04 works fine locally.

Have you implemented any firewall at all for the server?

Only office needs to be able to address it’s own external interface.

It’s never a good idea to offer up root passwords etc to allow a complete stranger access to your server, do you know what else they’ll do when granted access?

You should be able to work through this yourself with a little help.

Do you have a FQDN for you Onlyoffice installation? e.g

Hi NeptuneUK… My Mageia server runs in virtual on Windows machine, so give somebody helpful my root password is not so strange. I think. Of course, I would change my original root password before. Thank you for your replay. I do not like Ubuntu. Mageia (Mandriva, Mandrake…) is Linux distribution, what I tried first in 2001. I like it most of all distros. No. I do not have any FQDN. I want to start OnlyOffice on the same machine, where my Linux runs. So?
What should I do first, please?


How did you install OO… Docker, Snap, manually, other?
If you followed an installation guide, which one?
So you enabled the Onlyoffice app via Nextcloud?
Do you have a firewall running on the VM linux instance?


In Ubuntu is problem with certificate and ssl/tls crypt nextcloud web… So I tried to use all installation options. Manually first, after snap and tried every guides on the web… Now I have installed Ubuntu 18.04 desktop. I did it yesterday. Should I try snap install all the futures of Nextcloud? How to do it without own domain? And firewall is off… OnlyOffice was enabled through apps in nextcloud… Thank you for your answer…



So to be clear:

1.) You have installed NC using snap on Ubuntu 18.04?
2.) You have a working NC install?
3.) Can you can access NC login, then login, and views files etc in NC web interface over http (port 80)?
4.) Can you can access NC login, then login, and views files etc in NC web interface over https (port 443)?
5.) Is this installation being used only on an internal / private network? (You don’t need a public FQDN to run NC).
6.) Have you installed OnlyOffice Document server?
7.) Is this the first time you have used / installed NC?

Let’s just walk through things slowly.

Now my server runs on Ubuntu 18.04 without nc. I have installed php, apache2, mariadb, phpmyadmin and webmin. To install nc using snap server works fine (without ssl/tls) and then may I install docker and onlyoffice document server? Then I will allow onlyoffice in nc. No, I am trying to install Onlyoffice to nc 2-3 month… But still not working…
Should I start?

ou may try this on a new ubuntu 18?

Hi. Thank you. Installation was successful, but nextcloud dont work. I changed trusted domains for LAN, and WAN ip address but nothing shows. Whatever I can do, please?
Thank you.

at the end of the play you get something like

ok: [localhost] => {
    "msg": [
        "Your Nextcloud at https://nextcloud.example.tld is ready.",
        "Login with user: admin and password: fTkLgvPYdmjfalP8XgMsEg7plnoPsTvp ",
        "Other secrets you'll find in the directory /opt/nextcloud/secrets "

that’s the url you can access your nextcloud with. dns resolution must work for this address. unless you use the ip address.

you must edit the inventory file to fit to your needs.

if that’s your problem you can change the value in the inventory and re-run the playbook. no need to start from scratch.

Thank you. I did it and… IP address shows It works! and IP/nextcloud shows 404 Not Found nginx/1.14.0 (Ubuntu)… I do not have any domain. I only want to runs nextcloud on my server with Onlyoffice, or Collabora Online. If it is not able to works without domain, I will have to buy M$ Office 365 Professional Plus… Thank you very much…
Best regards…

no need to buy a domain. just configure your dns and/or /etc/host correct.

since i’m using taefik (because it handle ssl certifcates so nice and easy) one has to give the nginx web server a “name”. that is either the ip address of the host or whatever you put into your home dns and/or /etc/hosts files.

if you look at the other playbook (selfhosted) you can put a lot of services behind a traefik container. but each service endpoint needs a dedicated name.

I did it… “nextcloud_server_fqdn” is now “WAN IP address”… Still the same… Now I am trying to restart the server… Can you tell me, how to install and setup ssl certificate? It can by installed on Ubuntu only with name of domain… On Mageia Linux works nc from start with https without problems…

the wan ip address is wrong. it must be the local ip address of your nc host.

that is handled by traefik out-of-the-box.

if you used the nextcloud_on_docker playbook.

fatal: [localhost]: FAILED! => {“changed”: false, “msg”: “Error starting container 0da6a177479da39072a2e78ca645bdfa77c648a3338a083c9df9047b9cb2a75a: 500 Server Error: Internal Server Error (“driver failed programming external connectivity on endpoint traefik (aa876c21524085752bc4ace2de81ea627c8ee4509388b9b8d76566b4f2c60d89): Error starting userland proxy: listen tcp bind: address already in use”)”}

After change WAN IP to LAN IP (not…

stop or remove the existing web server if any:
sudo systemctl stop apache; sudo systemctl disable apache
or stop the existing traefik container:
sudo docker stop traefik ; sudo docker rm traefik

Did not help. There is no apache server running on the server. Only WAN IP address show ngins thank you page. IP/nextcloud 404… Firewall is disabled… I will try LAN IP…

I installed ubuntu live server 18.04 and try your action. After install nextcloud my server wrote this…

Do you have any idea, please?
Thank you.

my best guess is that something with the variable nextcloud_server_fqdn was wrong.

I just tested it with nextcloud_server_fqdn = got:

TASK [We are ready] ********************************************************************************************************************************************
Monday 03 June 2019  21:07:04 +0000 (0:00:00.096)       0:01:28.602 ***********
ok: [localhost] => {
    "msg": [
        "Your Nextcloud at is ready.",
        "Login with user: admin and password: D89zfeaqBFh7aQSkE83TsjwnAoZVMp3u ",
        "Other secrets you'll find in the directory /opt/nextcloud/secrets "

TASK [We are ready] ********************************************************************************************************************************************
Monday 03 June 2019  21:07:04 +0000 (0:00:00.098)       0:01:28.701 ***********
skipping: [localhost]

TASK [We are ready] ********************************************************************************************************************************************
Monday 03 June 2019  21:07:04 +0000 (0:00:00.093)       0:01:28.795 ***********
skipping: [localhost]

PLAY RECAP *****************************************************************************************************************************************************
localhost                  : ok=68   changed=8    unreachable=0    failed=0    skipped=27   rescued=0    ignored=0