Mac client cannot login to server

Nextcloud Version 2.6.4stable (build 20200303)
Operating system and version: MacOS 10.15.3

I try to add nextcloud client to MacOS and sync data. Never had problem with that earlier. Now i just get a blank screen when I expect the login page to show. I can see the login form very briefly, a few milliseconds, and then it flickers and shows a blank screen. See images below. It works perfectly accessing the server via a web browser.

Hi ecce,

please could you try the solution from this thread: Problem with iMac and Nextcloud Desktop app

Maybe this solves your problem as well

1 Like

Looks like there is a problem with v2.6.4 on OS X .

@ecce does your Nextcloud server runs on Nginx or Apache for the web service ?

I’ve got the v2.6.4 on macOS 10.14.6 (Mojave) and it’s working fine - Haven’t tested it on 10.15 (Catalina) yet.

And you are on Nginx or Apache ?

We’ve got both - Apache 2 as the webserver and nginx as the reverse proxy

Alright, i will install the v2.6.4 on a Mac.
I have Nginx as a front server
EDIT : i can’t i have 10.11 El Capitan…

That worked! Thank you!

I can confirm that on macOS Catalina 10.15.5 the following package does not work as expected (login form briefly appears then is covered by blank screen).

An older package is working, as mentionned by CFelix

Is there a bug open in the tracking database ? that’s definitely an issue that must be fixed for new users :slight_smile:

Thank you,

I just tried the installation and setup of the NC client 2.6.4 on my macOS Catalina 10.15.5 testing machine and did not have any issue :thinking:

After entering the URL to my NC, it opened the Safari browser in which I had to login with my credentials. After entering my credentials I just had to grant access and the client was connected.

Maybe this could have something to do with the security & privacy settings but I am not sure.

Thank you for your message and for your tests.
On my mac, Firefox is the default web browser. May be worth a try :wink:
(I cannot do it myself currently because I’m sync’ing a huge folder).
Will do tomorrow (revert to Safari as default web browser) and let you know.
Best regards

We have fixed it:

This is just a daily build but the fix will be included in the 3.0.2 release next week.