Mac 3.0 desktop not syncing

I have been using Nextcloud for a couple of years and have never seen this behavior, so I am looking for troubleshooting assistance.

I was seeing the same behavior on the 2.6.4 client, but currently I have one MacOS 10.15.5 machine running the 3.0 desktop client that is not syncing with the server. We have 285GB in a NextCloud 14.0.6 server that syncs properly to other clients. (Yes, I know it’s out of date, but that shouldn’t be causing what I am seeing.)

In the past when I had a problem with a sync client it was due to a conflict. I found the conflicting files, deleted/moved them, and it resolved on its own. This client is not ever generating a csync journal file. I have looked in the log and watched several MB of mundane messages whiz by. I have looked at the server logs and nothing jumps out at me. If I can’t figure out what the problem is, I guess I could back up the local copy on that machine (which has changes that aren’t synced to the server), resync from the server, and manually integrated the changes.

But I would prefer to figure out why it isn’t syncing. What should I be looking at?

You are 5 major version behind with your server. Maybe the clients don’t support Version 14 anymore?

  1. I know the server version is out of date, but…
  2. The last time I did a major upgrade cycle was only about 14 months ago and at the time, I tried installing version 15.x and it had data-destructive bugs.
  3. The 2.6.x client wasn’t working on this machine either, when the 2.6.x client and this server version are working fine on several other Windows and MacOS machines.
  4. If the client doesn’t support the server version anymore, shouldn’t there be some logic built into the client to at least display a warning?

I have been able to get this client to sync using the 3.0 client by blowing away the current configuration in ~/Library/Preferences/Nextcloud, de-selecting some folders, and adding folders back into the sync set one at a time. (After one finishes syncing, I add another one.) I think it was just hitting some kind of timeout when I tried to sync everything at once.