Lost access via domain name. Could have been accidental change of IP assignment

Nextcloud version 17.0.2:
Operating system and version Ubuntu 18.04
Apache or nginx version _Apache 2.4.29
PHP version , 7.2.24

After a couple of months of trouble-free cloudiness, my server became inaccessible today. When I got home and checked it, the IP for the Nextcloud box had changed. I could have sworn I’d assigned it a static IP.
Anyway, I can now access Nextcloud via the IP, but not via the domain name. This means it’s not available outside my house. Very vexing.
Can you suggest what order of checks I should do, please?
Kind regards,

Is this the first time you’ve seen this error? (Y):

Steps to replicate it:

  1. Don’t know.

The output of your Nextcloud log in Admin > Logging:

There’s nothing from after 1st Jan and nothing relating to this. The entire log runs to 100 000 characters and the forum software rejected it.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ocauxspzutuc',
  'passwordsalt' => 'XXXXXXXXXX',
  'secret' => 'fGfE7Ur/2yXXXXXXXXXXXXXXX',
  'trusted_domains' => 
  array (
    0 => '192.168.1.XXX',
    2 => 'cloudXXXXXXXXX.uk',
  'datadirectory' => '/var/www/html/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'nextcloud',
  'dbpassword' => 'XXXXXXXXX',
  'installed' => true,
  'maintenance' => false,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'admin',
  'mail_domain' => 'XXXXXXXX.uk',
  'mail_smtpauthtype' => 'PLAIN',
  'mail_smtphost' => 'smtp.XXXXXXX',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'admin@XXXXXXX',
  'mail_smtppassword' => 'XXXXXXXXXXX',
  'has_rebuilt_cache' => true,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:

Sorry, I don’t know which file this is. There’s an Apache folder with lots of log files in it, but none is called Apache system. Sorry.


first of all i’d check if ports at router are forwarded to correct internal (new) ip.

Will do. Thanks. I’m trying to set aside tomorrow to grapple with this.
I really appreciate you giving me some guidance about where to start.
Thanks again.

1 Like

Maybe you can assign the old IP as static new address to the box in your router; after rebooting the box it should retrieve the IP from the router.
Then check the open ports and if thery’re going to the right IP.

Larsnikk and Jimmy Kater, thank you both very much. I’ve got a clearer picture now.
I’ve got more information, if you’re interested! I think it makes things clearer.
My ISP had to change my static IP address, as it was interfering with other networks on the same street box. They neglected to tell me this, but I’m not going to get too het up about it, as they’re waving the static address fee for six months, which is cool.
Anyway, I’ve changed my domain name’s A record to my new IP address, and then have to wait for that to propagate, of course. More excitingly, later today, my ISP are delivering a booster for the house wifi, (free!) after which they’ll do a reset on the router and reinstall the settings I had before they tinkered.
If it was a national company, I’d be up in arms, but it’s the local fibre company on the Isle of Wight, and so I know some of the people who work there and am fairly okay with this. I’m only going to give them three stars for the communication: they really should have let me know that my service would disrupted to this extent. However, I am very happy with the long term outcome. The fact that I can expect one of their network team to actually come to my house this afternoon is a huge boon. I;m compiling my list of “Just one more thing,” questions already. The poor guy won’t know what hit him.

1 Like