Loolwsd.service does not start // Collabora Online


#1

I have restructured the server and restored my previous state. Nextcloud itself runs without problems. But a problem occurred at Collabora. loolwsd does not start.

loolwsd.service - LibreOffice Online WebSocket Daemon
   Loaded: loaded (/usr/lib/systemd/system/loolwsd.service; disabled; vendor preset: disabled)
   Active: failed (Result: start-limit) since Sun 2018-12-02 17:32:21 JST; 5s ago
  Process: 7472 ExecStart=/usr/bin/loolwsd --version --o:sys_template_path=/opt/lool/systemplate --o:lo_template_path=/opt/collaboraoffice5.3 --o:child_root_path=/opt/lool/child-roots --o:file_server_root_path=/usr/share/loolwsd (code=exited, status=70)
 Main PID: 7472 (code=exited, status=70)

Collabora is installed as a package for CentOS, not Docker version. Please tell me how to start loolwsd.

// Added
Is this a certificate problem? I tried running loolwsd directly and it seems that the following error occurred.

wsd-24911-24911 2018-12-02 15:12:14.179972 [ loolwsd ] FTL  Cannot load CA file/directory at /etc/loolwsd/ca-chain.cert.pem (error:02001002:system library:fopen:No such file or directory)| wsd/LOOLWSD.cpp:3153
Cannot load CA file/directory at /etc/loolwsd/ca-chain.cert.pem (error:02001002:system library:fopen:No such file or directory)

I use a wild card certificate by using Let’s Encrypt as a certificate.
I was not a wild card certificate before. What is the cause? Is there a way to run a site for Collabora Online with a wild card certificate?


CentOS 7.5 / Nginx 1.13.8 / PHP 7.1.23


#2

I solved my self.
I thought that only “/etc/loolwsd/” was restored from backup data and it was restored without problem. But in fact it was not restored. I manually restored and put those .pem files in it. Now loolwsd got started safely.