Logout not possible (18.0.4) - everyone has access to the files

We just installed Nextcloud 18.0.4 via Web-Installer. Unfortunately, SSH access is not available; only FTP and Control-Panel access is available (due to limitations of shared hosting).

Everything seems to work fine, however, logging out is not possible. On clicking “Logout”, there is always a redirect to the file screen. However, we were able to create a new user.

The nasty thing is: Everyone who knows the subdir has access to the files - no need to login!

We terminated all open sessions, but it didn’t help.

We experimented with upgrading to 19.0.0 beta 7, but it didn’t resolve the problem neither. Instead, there are now integrity warnings in the Security and Installation dashboard.

The error message in the logs is as follows:
session_start(): A session had already been started - ignoring at …/nextcloud/lib/private/Session/Internal.php#209

Is there any solution to resolve this?

Clarify on how to replicate this.

Trying to log-out via Web-UI (unsuccessfully tried with Opera, Google Chrome, IE 11, MS Edge): Click on profile picture corner top right - Menu appears (Settings, Apps, Users, …) - Clicking on “Log out”.

Works here…

Maybe ask your shared host about this?

I doubt that since log-out (and log-in) worked in the beginning.

The only change in between was a rename of the Install-Directory, which did not work. After changing the name of the Install-Directory back to its previous one, Nextcloud worked again, but the log-out problem occurred.

Okay, good luck!

Yes, I am afraid I have to shift the files to another cloud and install Nextcloud again from scratch.

This issue also does not exist on NC19 RC1.

I’m not sure why you’re seeing this issue but I would point fingers at the host before nextcloud. Especially since it’s an error regarding sessions.

OK, I will contact them.


I modified / extended the config.php as follows:

‘remember_login_cookie_lifetime’ => 60 * 60 * 24 * 15,
New value: 0

‘session_lifetime’ => 60 * 60 * 24,
Temporary new value: 1

Finally, it worked - I got kicked out and could do a new log-in.