Login Inputs missing

Nextcloud version: 17.0.2
Operating system and version: Debian 10
Apache or nginx version: nginx 1.14.2
PHP version: 7.3

The issue you are facing: When I want to login in the Web UI, I just get a login page without inputs, just a page with the nextcloud logo and a background. No errors in the browser console. Sync clients are not able to connect aswell.

Is this the first time you’ve seen this error? (Y/N): Y

The output of your Nextcloud log in Admin > Logging: Cannot login, so not able to see that.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'debug' => true,
  'instanceid' => '--',
  'passwordsalt' => '--',
  'secret' => '--',
  'trusted_domains' =>
  array (
    0 => 'cloud.---.--',
    1 => 'cloud.---.---',
  'datadirectory' => '/var/www/cloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://cloud.---.---',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'nextcloud',
  'dbpassword' => '---',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'cloud',
  'mail_domain' => '---.---',
  'mail_smtpauthtype' => 'PLAIN',
  'mail_smtphost' => '',
  'mail_smtpport' => '25',
  'theme' => '',
  'maintenance' => false,
  'loglevel' => 3,
  'mail_smtpauth' => 1,

This started happening after I updated my Debian from 9 -> 10 and switched from Apache2 to nginx. I already did a occ check without success.

Does nobody have an idea?

The login is not disabled, it just isn’t there.

I’m still pretty sure that if you follow the advice from the issue (you probably have to scroll down a bit) you will figure out the problem :wink:

Thanks for your help.
Unfortunately I just tried everything and the problem persists.

So I found out the issue was the Cloudflare Rocket Loader. I disabled it and now it works.