Logging in takes forever when using domain -- help?

OS: Ubuntu 20.4.1
How I installed: Snap Package
Version: 19.0.1snap3
Other setup info: Using a Caddy Reverse Proxy, bit more at the end of this post.

Issue: When accessing my nextcloud instance through my domain name(e.g. nextcloud.example.com), I can’t get past the login screen after entering my credentials(it just keeps loading forever). When on the host machine, localhost and work fine, haven’t tried on other devices besides domain access yet.

Other info: Using Cloudflare DNS – tried enabling/disabling proxying through Cloudflare, didn’t change the results.

Attempting to follow a guide on a GitHub issue revealed the following error in my Brave(Chromium based) Console(some info wouldn’t copy, mainly just parts of the link[error is still there]):
Refused to send form data to 'http://nextcloud.example.com/' because it violates the following Content Security Policy directive: "form-action 'self'".

Another note: I have https(caddy reverse proxy) enabled, don’t know if that has anything to do with it

Figured it out, appears using a reverse proxy doesn’t let Nextcloud know that you’re using https, adding the following like to my config.php fixed the issue:
'overwriteprotocol' => 'https',

I’ll keep this here for other users’ reference.