Logging admin page does not show any log entry

When I go to logging page, there is only the drop down of log severity, but no logs are shown. All empty/blank.

OC: 10.0.1
Firefox 50
Windows 10 Pro x64


What is written in your config.php for logging settings?

'log_type' => 
'logfile' =>
"system": {
    "instanceid": "oclo0wchh5q0",
    "passwordsalt": "***REMOVED SENSITIVE VALUE***",
    "secret": "***REMOVED SENSITIVE VALUE***",
    "trusted_domains": [
    "datadirectory": "\/var\/owncloud_data",
    "overwrite.cli.url": "***REMOVED SENSITIVE VALUE***",
    "dbtype": "mysql",
    "version": "",
    "dbname": "owncloud",
    "dbhost": "localhost",
    "dbtableprefix": "oc_",
    "dbuser": "***REMOVED SENSITIVE VALUE***",
    "dbpassword": "***REMOVED SENSITIVE VALUE***",
    "installed": true,
    "forcessl": false,
    "forceSSLforSubdomains": false,
    "loglevel": 2,
    "log_rotate_size": 104857600,
    "logfile": "\/var\/log\/nextcloud.log",
    "logtimezone": "Europe\/Berlin",
    "has_internet_connection": true,
    "check_for_working_webdav": true,
    "check_for_working_htaccess": true,
    "maintenance": false,
    "theme": "",
    "preview_max_scale_factor": 1,
    "asset-pipeline.enabled": false,
    "trashbin_retention_obligation": "auto",
    "apps_paths": [
            "path": "\/var\/www\/nextcloud\/apps",
            "url": "\/apps",
            "writable": false
            "path": "\/var\/www\/nextcloud\/apps2",
            "url": "\/apps2",
            "writable": true
    "updatechecker": true,
    "mail_smtpdebug": false,
    "mail_smtpmode": "php",
    "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpport": "587",
    "mail_smtptimeout": 10,
    "mail_smtpsecure": "tls",
    "mail_domain": "***REMOVED SENSITIVE VALUE***",
    "mail_smtpauthtype": "LOGIN",
    "mail_smtpauth": 1,
    "mail_smtpname": "***REMOVED SENSITIVE VALUE***",
    "mail_smtppassword": "***REMOVED SENSITIVE VALUE***",
    "memcache.local": "\\OC\\Memcache\\APCu",
    "mail_from_address": "nextcloud",
    "htaccess.RewriteBase": "\/owncloud",
    "singleuser": false

I have added “log_type”, but this didnt work either. I saw that root owned the logfile and changed it to www-data for testing purpose. it has solved the issue. But is it intended that www-data owns the file? Or do I simply have to apply the correct group permissions?

As I understand it /var/log/ usually contains logs with access right for root and syslog users or adm group members - mainly.
As you noticed nextcloud needs www-data ownership to read its log. That is why the log is usually placed in the NC data folder, for example /var/ncdata/
And this folder has www-data ownership then:
drwxr-x--- 11 www-data www-data 4096 Nov 25 13:09 ncdata

Did your logging actually work? I mean did the logfile contain log entries (before you changed the ownership)?
I’d would expect that Nextcloud can’t create log files in /var/log itself and even if one creates the log file manually, there will be problems with log file rotation.
Maybe I’m totally wrong and would have a different approach for the nextcloud logging as well :slight_smile:

Have the same issue, since the update to Nextcloud 11 Beta RC2:

‘logtimezone’ => ‘Europe/Berlin’,
‘syslog_tag’ => ‘Nextcloud’,
‘log_type’ => ‘file’,
‘logfile’ => ‘/var/log/nextcloud.log’,
‘loglevel’ => 0,
‘log_query’ => false,
‘cron_log’ => true,
‘logdateformat’ => ‘F d, Y H:i:s’,
‘log_rotate_size’ => false,

/var/log/nextcloud.log has valid content:

{“reqId”:“lA+eTNAhxuLINaVV4ZzX”,“remoteAddr”:"",“app”:“cron”,“message”:“Finished OCA\Files_Retention\BackgroundJob\RetentionJob job with ID 51”,“level”:0,“time”:“December 13, 2016 20:45:01”,“method”:"–",“url”:"–",“user”:"–",“version”:“”}

The Permissions: ll /var/log/nextcloud.log
-rw-r----- 1 www-data www-data 15K Dez 13 20:45 /var/log/nextcloud.log

I also have this problem since the upgrade.

I accidentally de-clicked all the log-features, and the log disappeared.

I’ve set the config.php loglevel to 0, tried 2.

The default logfile location is ncdata/nextcloud.log, and it does contain some lines.

I’ve tried to rm -r logreader, and wget 2.0 logreader, extracted it in apps, only to finally add it as an active app, without any result. The log/admin page doesn’t read into the nextcloud.log, “Everything is working” Man oh man, I wish I didn’t declick the logging features.

Well contrary to my first post - it is working; but a hell of a lot less errors are either a) not occurring b) not getting logged.

I did try to login from an untrusted domain, that did not get logged, you can try that aswell.

Just did at clean install, and logs works again. Then when I godt everything/data on to the server again, all the logs disappeared. Checked logs at time: 22.05 logs ok, checked 02.03 no entry in the logs, “everything ok” was previous lots of entry’s, how’s that OK 3-4 hour later?

This looks like a bug to me. The problem is that the top bar is only displayed when there is something to show. By disabling all log levels all entries disappear.

To get your logs back you have to update your nextcloud database by running

UPDATE ‘your database here’.‘oc_appconfig’ SET ‘configvalue’ = ‘11111’ WHERE ‘oc_appconfig’.‘appid’ = ‘logreader’ AND ‘oc_appconfig’.‘configkey’ = ‘levels’;

to reset all shown log levels.


This also happened to me today. I’m on Nextcloud and tried to hide a lot of fatal log entries in my admin log page by un-ticking the checkbox for fatal log entries. After that nothing loaded on the log page just as flowlee stated above.

I’m not that experienced with mysql database manipulation so it took me some time to modify the code above to work for me. I logged in to mysql and loaded my nextcloud database. Then I checked the value of the specified row to try my command:

mysql> SELECT * from oc_appconfig WHERE appid='logreader' AND configkey='levels';
| appid     | configkey | configvalue |
| logreader | levels    | 11110       |

and then updated the value:

mysql> UPDATE oc_appconfig SET configvalue='11111' WHERE appid='logreader' AND configkey='levels';
Query OK, 1 row affected (0.01 sec)
Rows matched: 1  Changed: 1  Warnings: 0

That solved it for me. Thanks for pointing me to the right row!
This is the related issue on github: https://github.com/nextcloud/logreader/issues/35