Local MemCache APCu with CronJob not Working

Hello, everyone,

I have a problem, my Nextcloud (hosted at Domainfactory) is actually running great. Now I want to activate the Local MemCache (APCu).
This works too. BUT:
After activating my MemCache in the config, my 5-minute cron job is no longer executed. I get the following error message:
OCP\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache
(Is the matching PHP module installed and enabled?)

However, the module is installed and activated.

Can someone help me?

Thanks very much!

Please check other postings on this forum which are convering this topic. Most likely you’ve only configured the PHP WEB component and have forgotten to configure the PHP CLI (command line interface) component. IT is also possible tha you’Re using different PHP versions for the PHP WEB and CLI components.


Memcached configuration is poorly documented in Nextcloud. The dependencies have been installed and your config.conf is correct, no warings in the Administration settings. You have to add --define apc.enable_cli=1 to your cronjob. This is to inform php-cli that memcached is present.