Linux client window always opens on login

Whenever I log in on Debian with the Linux Desktop Sync client running, the main gui always opens. Running on Linux Mint, this doesn’t happen. Is there some way of setting the gui to not open on desktop login on Debian?

I found the culprit. I’m using XFCE, and for some reason if nextcloud was opened during a session (and that session was saved for next startup) it keeps opening the client. As it’s registered as a startup application, the service runs and then the second instance triggered by the saved session also gets triggered which prompts the gui to open.

The solution is to open saved sessions in the startup preferences of your desktop and untick nextcloud, thus removing it from the saved session. It must be left turned on in the startup applications, however.

On Linux Mint 19, I’ve found that a delay is also required for startup if using Cinnamon desktop, otherwise the icon won’t appear in the status bar.