Linux client doesn't copy any file

Hello,
I installed Nextcloud client on a new Linux computer.
It is running Ubuntu 20.04.3 LTS.
The account configuration went well : I’ve been sent to web interface, logged in, and allowed the device to use the account.
But then, no data is copied. Nothing at all. The folder that I’ve created to host the files is empty.
And I see this message error : “… Operation canceled… Folder not found…”.
It looks like the client is not allowed to create folders :frowning: I have checked in the computer settings, Nextcloud client is allowed to access to my files.
Any idea ?

In the settings of the client, is the folder added to “Sync Connection”? If yes, try to force the synchronization using the menu next to the instance (press the tree dots)

Hello,

Yes.

I’ve already tried several times. Also tried to relaunch Nextcloud client.

And I just restarted the computer, the problem is still there.

In case you did not check already:

  • Does the folder exist?
  • What is the owner of the folder?
  • What are the access rights?
  • What user starts the client?
1 Like

Yes

The only user on the computer : me

My account can modify

It is started when my session is running. But I’m not sure this answers your question

I would exit the client and start it again in a shell on the command line. Perhaps it throws some error messages there.

How can I do that ?

Don’t you have command line access to the system? You said “installed Nextcloud client on a new Linux computer”. Tell exactly what computer that is and how you installed Nextcloud.

Yes, I do have access to command line. My question was “how do I start the client with command line ?”

I installed Nextcloud client with “Logiciel” (aka “Software”), bundled with OS. Its about window :
Capture d’écran du 2022-03-07 07-44-49

I don’t know your system. The nextcloud executable should be somewhere on your path. Try

which nextcloud

or

nextcloud (press–>TAB)

to find it. On Ubuntu it should be in

/usr/bin
/usr/local/bin
or maybe in
/opt/…

Hello,
Thanks for the help. I got some response :
$ which nextcloud didn’t get any answer

nextcloud (press–>TAB) was better :

$ nextcloud-desktop-client.nextcloud
Gtk-Message: 08:30:49.009: Failed to load module "appmenu-gtk-module"
Qt: Session management error: Could not open network socket
Warning: Setting a new default format with a different version or profile after the global shared context is created may cause issues with context sharing.
nextcloud.gui.application: Already running, exiting...

But I don’t know what to do with it.

I found this in the software description (by snapcraft.io) :

Following are needed interfaces for the client. When these interfaces are not connected, the client won’t work as expected:
sudo snap connect nextcloud-desktop-client:mount-observe sudo snap connect nextcloud-desktop-client:network-manager-observe sudo snap connect nextcloud-desktop-client:password-manager-service

So, I executed the 3 commands, then exited and restarted Nextcloud, but it makes no difference.
I also found the authorizations of the software. I saw that it did not have the 3 mentioned authorizations, gave it, restarted software again, but the problem is still the same…

Do you have root access to the box? Try this:

sudo apt install appmenu-gtk-module-common
sudo apt install appmenu-gtk2-module
sudo apt install appmenu-gtk3-module

to get the missing module installed.

After each command, it says that it is already installed with the last version.