Linux Client bei Domainumstellung verbindet nicht

Hallo zusammen,
ich habe die Sync-Verbindung fĂŒr den Server gelöscht, da dieser eine neue Domain erhalten hat. Beim Versuch eine neue Verbindung aufzubauen öffnet der Client Firefox und gibt folgende Meldung aus:

Zugriff verboten Dein Anmelde-Token ist ungĂŒltig oder abgelaufen

Das Logfile zur Anmeldung gibt die folgenden Meldungen aus:

|[OCC::FolderMan::setupFoldersMigration |Setup folders from  "/home/xxxxxxx/.config/Nextcloud/folders" (migration)|
|---|---|
|[OCC::ClientProxy::setupQtProxyFromConfig |Set proxy configuration to use the prefered system proxy for http tcp connections|
|[OCC::ownCloudGui::slotOpenSettingsDialog |No configured folders yet, starting setup wizard|
|[OCC::WebViewPage::WebViewPage |Time for a webview!|
|[OCC::OCUpdater::backgroundCheckForUpdate |Checking for available update|
|[OCC::AccessManager::createRequest |2 "" "https://updates.nextcloud.org/client/?client=RGlzdHJpYnV0b3IgSUQ6CVVidW50dQpEZXNjcmlwdGlvbjoJVWJ1bnR1IDE4LjA0LjMgTFRTClJlbGVhc2U6CTE4LjA0CkNvZGVuYW1lOgliaW9uaWMK&version=2.6.0.0&platform=linux&oem=Nextcloud&versionsuffix=git" has X-Request-ID "yyyyyyyyyyyyyyyyy"|
|[OCC::PassiveUpdateNotifier::versionInfoArrived |Client is on latest version!|
|[OCC::OwncloudSetupWizard::slotSystemProxyLookupDone |No system proxy set by OS|
|[OCC::AccessManager::createRequest |2 "" "https://xxxxxxxxxxxxxxx.my-domain.de/status.php" has X-Request-ID "yyyyyyyyyyyyyyyyy"|
|[OCC::AbstractNetworkJob::start |OCC::CheckServerJob created for "https://xxxxxxxxxx.my-domain.de" + "status.php" "OCC::OwncloudSetupWizard"|
|[OCC::CheckServerJob::finished |status.php returns:  QJsonDocument({"edition":"","installed":true,"maintenance":false,"needsDbUpgrade":false,"productname":"zzzzzzzzzzz","version":"16.0.4.1","versionstring":"16.0.4"})   QNetworkReply::NetworkError(NoError)  Reply:  QNetworkReplyHttpImpl(0x560ff4f06fa0)|
|[OCC::DetermineAuthTypeJob::start |Determining auth type for QUrl("https://xxxxxxxxxx.my-domain.de/remote.php/webdav/")|
|[OCC::AccessManager::createRequest |2 "" "https://xxxxxxxxxx.my-domain.de/remote.php/webdav/" has X-Request-ID "yyyyyyyyyyyyyyyyy"|
|[OCC::AbstractNetworkJob::start |OCC::SimpleNetworkJob created for "https://xxxxxxxxxx.my-domain.de" + "" "OCC::Account"|
|[OCC::AccessManager::createRequest |6 "PROPFIND" "https://xxxxxxxxxx.my-domain.de/remote.php/webdav/" has X-Request-ID "yyyyyyyyyyyyyyyyy"|
|[OCC::AbstractNetworkJob::start |OCC::SimpleNetworkJob created for "https://xxxxxxxxxx.my-domain.de" + "" "OCC::Account"|
|[OCC::DetermineAuthTypeJob::checkBothDone |Auth type for QUrl("https://xxxxxxxxxx.my-domain.de/remote.php/webdav/") is 4|
|[OCC::AccessManager::createRequest |4 "" "https://xxxxxxxxxx.my-domain.de/index.php/login/v2" has X-Request-ID "yyyyyyyyyyyyyyyyy"|
|[OCC::AbstractNetworkJob::start |OCC::SimpleNetworkJob created for "https://xxxxxxxxxx.my-domain.de" + "" "OCC::Account"|
|[OCC::Flow2Auth::openBrowser()::<lambda |setting remote poll timer interval to 5000 msec|
|[OCC::AccessManager::createRequest |4 "" "https://xxxxxxxxxx.my-domain.de/login/v2/poll" has X-Request-ID "yyyyyyyyyyyyyyyyy"|
|[OCC::AbstractNetworkJob::start |OCC::SimpleNetworkJob created for "https://xxxxxxxxxx.my-domain.de" + "" "OCC::Account"|
|[OCC::AbstractNetworkJob::slotFinished |QNetworkReply::NetworkError(ContentNotFoundError) "Error transferring https://xxxxxxxxxx.my-domain.de/login/v2/poll - server replied: " QVariant(int, 404)|
|[OCC::OwncloudSetupWizard::slotAssistantFinished |Rejected the new config, use the old!|

Die Anmeldung ĂŒber das Webinterface klappt problemlos.

Hat irgendjemand eine Idee, was falsch lÀuft?
Bernd

Die LogeintrÀge sind leider sehr schlecht zu lesen. Wenn jeweils vor und nach dem Logzeilenblock drei auf einander folgende Hochkommata setzt (grafik ) lassen sich diese defintiv besser lesen :wink:

Ich habe es mal schnell fĂŒr ihn (oder besser gesagt fĂŒr uns :stuck_out_tongue: ) geĂ€ndert.

@Catalano kurz ein paar Fragen:

  1. hast du auf dem Client alte Logindaten in Form eines App-Passworts verwendet? (falls ja, bitte mal ein neues App-Passwort generieren und das neue testen)
  2. hat sich sonst noch etwas am Server verÀndert? (NC-Version, Webserver-Config, 
)
  3. hat sich nicht ein Browser-Fenster geöffnet, in dem du den Login bestÀtigen kannst? Siehe die nachfolgende Meldung:

Vielen Dank erst mal fĂŒr die Erstellung des Codeblocks. Das mit den Hochkommata habe ich nicht gefunden.

  1. ein App Passwort habe ich verÀndert, ich komme aber nicht auf eine Seite, auf der ich ein Passwort eingeben kann

  2. ich habe nichts weiter verÀndert

  3. Es öffnet ich ein Browserfenster. In diesem kommt aber nur die Meldung “Zugriff verboten Dein Anmelde-Token ist ungĂŒltig oder abgelaufen”. Eine Passworteingabe ist nicht möglich.

Entschuldige, den Teil verstehe ich nicht ganz. Wie meinst du “App Passwort verĂ€ndert”?
Und du findest die Stelle nicht, wo die App-Passwörter erstellt werden? Nur falls ja und um die Antwort direkt zu liefern, das geht unter deinen persönlichen Einstellungen.

  1. Klick auf dein Bild oben rechts in der Ecke
  2. Einstellungen
  3. Links auf “Sicherheit” klicken
  4. im Bereich “GerĂ€te & Sitzungen” das Eingabefeld mit dem Button daneben “Neues App-Passwort erstellen” suchen
  5. im Eingabefeld einen Namen eintragen; sowas wie “Linux-Laptop”
  6. “Neues App-Passwort erstellen” klicken
  7. das angezeigte Passwort kopieren und irgendwo (zumindest temporÀr) sichern (am besten Passwort-Safe) und den BestÀtigen-Button klicken
  8. dieses App-Passwort als PW fĂŒr deinen Client verwenden

Da habe ich mich falsch ausgedrĂŒckt. Das App Passwort kann ich verĂ€ndern. Ich komme bei der Verwendung des Clients aber nicht zu einer Stelle, an der ich mich anmelden kann und irgend ein Passwort eingeben kann. Es erscheint keine Anmeldemaske.

Kannst du mal probieren, den Browser (den der Client öffnet) vorher schon zu öffnen und dich dort mit deinem User (den du auch im Client verwenden willst) einzuloggen?
Könnte ja sein, dass deine Session in dem Browser ausgelaufen ist.

Kannst du vielleicht mal eine Auflistung aller aktiven Apps schicken? Das occ-Kommando kann das mit
app:list

Mit dem VorgĂ€nger Client hat die Anmeldung funktioniert. Anschließend habe ich den aktuellen Client wieder ĂŒber die Paketquellen installiert. Funktioniert damit einwandfrei. Das scheint ein Problem des aktuellen Linux Clients zu sein. Zumindest berichten andere ĂŒber das gleiche Problem:
(https://github.com/nextcloud/desktop/issues/1412)
Vielen Dank!

1 Like