Link sharing from an external storage is no longer possible

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version 26.0.0
Operating system and version Ubuntu 22.04.2
Apache version 2.4.52
PHP version 8.0.28

The issue you are facing:

Sharing with public link from subfolders of an external storage (external storage tried via SMB and FTP) does not work anymore.
My link that worked for years was suddenly non-functional (Page not found). Under Activities from the directory it says “Shared as public link” but does not show the clipboard and properties icon.
Re-creating a link still seems to work, but that doesn’t work either and changing the properties results in the error is undefined

Will most likely have crept in with the update to 26.0.0.

Is this the first time you’ve seen this error? Y

Steps to replicate it:

  1. Select folder representation of or in an external storage
  2. Create public share link
  3. Change any property results in a error
  4. The link cannot be used (even if no properties have been changed)

Hi folks,

Unfortunately, I can perfectly reproduce this issue. Is there any solution for this?