LDAP users without email adress


I binded NextCloud with my AD but I have some problems with the users configuration.
I would like to have only users with an email adress not empty. So I modified the LDAP filter like that : (&(objectclass=user)(mail=*))
But I still have all the users without email adress when I go in the Users tab…

Does anybody know how to fix this problem ?

I’m sure that the attribute for the email in my AD is called mail so I don’t understand why I still have users without email adress…



You should check that.

Where are you setting the LDAP filter?

Ok, now it’s working. I didn’t change anything but I copied the configuration I had, I removed my configuration, created a new one and paste all the old one.

Thanks again !

Elise, you do tend to get faster responses via our support portal at https://portal.nextcloud.com - this forum is meant for home users, not business users!

Thanks, I din’t know.

1 Like