LDAP integration, Users found but not shown


Im struggling with LDAP integration. I supplied all credientials and tested connection. Users are found, but they are not shown for selection. in some Videos on YT it was said, that a logout and relogin might be necessary to show users for selection. Same problem with the groups. I verified the search strings and filters with ldapsearch, they seem to work and confirm that nextcloud indeed finds the users.

I also tried overriding UUID for users and groups, but did not notice any changes compared to default values.

Here is my user setup in ldap/ldif:


dn: cn=entwickler1,ou=users,dc=example,dc=de
cn: entwickler1
gidnumber: 500
givenname: entwickler1
homedirectory: /home/users/entwickler1
objectclass: inetOrgPerson
objectclass: posixAccount
objectclass: top
sn: entwickler1
uid: entwickler1
uidnumber: 1001
userpassword: {CRYPT}ssssssseeeeeeeeecccccccccrrrrrrreeeeeeeeettttttt

Filter for users:
Login Filter:
Filter for groups:

Any ideas how i can track down this problem further?

Problem solved.

In case you have a similar issue:

In my case everything worked correctly from the beginning, besides that in LDAP/AD-Integration dialog the users were not displayed.

When I looked into the Nextcloud Users they are alle displayed and nextcloud accounts have already been setup for each user from LDAP.

I have the feeling, that this was a font issue, but i cannot tell.

So: Do not look only for users showing up in the LDAP/AD-Integration, also look for the users in the Nextcloud users (Button in the top right->users)