"Large Files" not syncing via desktop client (but they're not big)

Fresh install, just got the desktop client to log in, and it mostly works, except for 155 items (compared to several thousand that worked). The client returns Server Replied "413 Request Entity Too Large" to "PUT http://cloud.odinforce.net/nextcloud/remote.php/dav/files/rhys/Documents/ Docs/StudyGuide/Volume 1/Lesson1.pdf
Same error for all files. Thing is, the files aren’t that big based on what I’ve read of the default 10M max. This particular file is 7.1MB. Another problem file is a 2.1 MB jpg.
I can’t find any 413s in any logs, access, error etc.
Here’s what I’ve done:
Modified /var/www/nextcloud/.htaccess to add the 3 lines below “#Added lines here”

<IfModule mod_php7.c>
  #Added lines here
  php_value upload_max_filesize 6G
  php_value post_max_size 6G
  php_value memory_limit 6G
  php_value mbstring.func_overload 0
  php_value default_charset 'UTF-8'
  php_value output_buffering 0
  <IfModule mod_env.c>
    SetEnv htaccessWorking true
  </IfModule>

Modified /etc/php/7.2/fpm/

; Maximum allowed size for uploaded files.
; http://php.net/upload-max-filesize
upload_max_filesize = 6G
.......
; Maximum size of POST data that PHP will accept.
; Its value may be 0 to disable the limit. It is ignored if POST data reading
; is disabled through enable_post_data_reading.
; http://php.net/post-max-size
# post_max_size = 1100M
post_max_size = 6G

And here is my Nginx server block:

server {
        server_name cloud.odinforce.net;

        access_log /var/log/nginx/cloud.example.com.access.log;
        error_log /var/log/nginx/cloud.example.com.error.log;

        client_max_body_size 0;
        underscores_in_headers on;

        ssl_stapling on;
        ssl_stapling_verify on;

        location / {
#               include config/odinforce.net/proxy.conf;
                client_max_body_size 10G;
                client_body_buffer_size 400M;
                proxy_headers_hash_max_size 512;
                proxy_headers_hash_bucket_size 64;
                proxy_set_header Host $host;
                proxy_set_header X-Forwarded-Proto $scheme;
                proxy_set_header X-Real-IP $remote_addr;
                proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

                # add_header Front-End-Https on;
                # whatever the IP of your cloud server is
                proxy_pass http://192.168.136.134;
        }


    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/odinforce.net-0001/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/odinforce.net-0001/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}

Also of note, these files upload fine if I use the web client, its only the desktop sync client that has issues.

Thanks for your time reading, please help,
Rhys

Same problem here
Nextcloud v19.0.3
Desktop for Linux v3.0.3
After complete synchronization, desktop client is unable to synchronize any new file, like a little pdf of 6.9mo: “413 entity too large”.
I updated php.ini with
upload_max_filesize = 256M
post_max_size = 0M (0M disable the limit)
Then restart ngingx, but (poor) same behavior… is there any solution? Thanks!